Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
'85 500SEL AMG, 91 560SEL, '99 E55, '00 SL600, '99 S600, '99 E300 TD, '92 190E
Joined
·
183 Posts
Discussion Starter #1
Hi,

I own a 1999 S600 with 60,000 miles. It is not a daily driver, I usually drive it once every two weeks. When I drove it Sunday, the power mirrors would not fold out and the driver side front window and passenger side back window would not roll down. Also, the steering column would not adjust. The suspension, ASR, SRS, and ABS lights are illuminated. I have checked all the fuses and disconnected the battery, but that didn't help. Any suggestions will be greatly appreicated.

Thanks,
Al
 

·
Registered
1995 MB S320V: 2006 kawasaki vulcan 900 lt
Joined
·
417 Posts
[:(]
the first thing i would do is check the condition of the battery. i doubt that driving it once every two weeks will keep it charged.
 

·
Registered
1996 S600 (Sebastian), 1999 SLK230 Kompressor (Tie Fighter)
Joined
·
638 Posts
if it is the battery, then you might want to connect it to a trickle charger while you're not using it. this will keep the battery fresh and snappy. [8D]
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
Indeed, these cars are Very voltage sensative. Unfortunetly, the electronics on these cars make it hard to diagnose w/o plugging the bugger in.

Jonathan
 

·
Registered
'85 500SEL AMG, 91 560SEL, '99 E55, '00 SL600, '99 S600, '99 E300 TD, '92 190E
Joined
·
183 Posts
Discussion Starter #5
Thanks guys, it was the battery. It was only holding 11 volts, enough to start the car, but not enough for the electrical system to work.

Thanks,

Al
 

·
Registered
W140 S600 300D300SD
Joined
·
226 Posts
how many times does a w140 need to be driven so that it can charge its battery? will it be enough if i use my s600 once a week?
 

·
Registered
94 s420 98 s420
Joined
·
539 Posts
Just curious why would the battery control the windows after the car is running? isnt that when the alternator come in? I tottaly disconnected my battery on a cadillac eldorado ( after starting )and everything functioned properly, all my accessories ran off the alternator. is it different for a benz? do some accessories run off the battery rather then the alternator after the engine started?
 

·
Registered
'85 500SEL AMG, 91 560SEL, '99 E55, '00 SL600, '99 S600, '99 E300 TD, '92 190E
Joined
·
183 Posts
Discussion Starter #8
I don't know, I guess some relays don't click when the key is in "on" position and after it starts it just bypass it. Also, they are very sensitive to power, it must have a safety feature or something and goes into dormiant mode, that keeps it from damaging any electonics.

Regards,
Al
 
1 - 8 of 8 Posts
Top