Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1984 SEL, 1999 ML 430, 2007 ML 500
Joined
·
18 Posts
Discussion Starter #1
Ok there are a lot of smart folks on this forum!

Here's my problem... I changed my alternator and the new one is in place. :)

But now I can't get the Serpentine Belt back on. :mad:

My specific problem is the took the pully off the front of the automatic belt tenisoner to remove the belt. Now the problem is how to get it back on. I have searched the forum to find a solution, but nothing specific with a 1999 ML 430 automatic belt tenisoner. So for those of you that are more experienced with this issue than me, here are the photos of what I'm talking about:

ML 430 1.1.jpg

ML 430 1.2.jpg

ML 430 1.3.jpg

I'm all greased up now and would like to get this back together ASAP. Any help as to how to get the serpentine belt back on a 1999 ML 430 will be most appreciated!
 

·
Registered
Dallas, Texas
Joined
·
6,834 Posts
Put E10 Torx socket on tensioner stud and rotate counterclockwise. Do something about oil puking on the belt. In this condition it's not going to last.
 

Attachments

·
Registered
1984 SEL, 1999 ML 430, 2007 ML 500
Joined
·
18 Posts
Discussion Starter #4
Thanks...

It's simple when you know what to do. It was a breeze to slip the belt over the alternator pully. Now on to changing the engine gasket to plug the oil leak.

I really appreciate the input,
 

·
Registered
1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Joined
·
7,035 Posts
Understand about the oil gasket - however, what Wi was trying to say is that those pulleys and that area need to be cleaned up too - old oil accumulation has to go, or ot will degrade your new belt for sure.

If it was me, now that you have gone thru the process once, I would get to a self-serve car wash and with the engine not-too-hot, take the belt off and get rid of all that old gunk with high pressure hot water, then put the belt back on.

Keep the beat !
 
1 - 5 of 5 Posts
Top