Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hi everyone,

I have a situation with my 99 E300TD. All has been well until recently the engine light went on. Occasionally when I turn the key in the ignition, the car revs very loudly and takes quite a few seconds to calm down. There is also a major loss of power and I have stopped driving it. It seems I have to push the gas almost twice as hard to maintain a speed.

Also, after I stop the car there seems to be a lingering electric crackling sound coming from the right (drivers side) of the engine. I should also mention that the car is sometimes jumpy at slow speeds, when it is shifting gears.

I hope to get a handle on the issue before finding a mechanic...
Please let me know if you can help thanks.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Other than then check engine light, the display reads "ASR/Skid control". Every now and again, "Brake lining wear" comes up, but I have had it checked twice and there are no issues with that...
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
Ok thanks, will do, though I thought "limp mode" would have kept me only in 2nd gear? I'm thinking I should take it to the dealer this time. After the brakes checked out before and I feel no problems either, I suppose I should get a third opinion.
 

·
Registered
Joined
·
35,795 Posts
Transmission 2nd level limp mode keeps it on 2nd gear. That is why I called this safe mode, that happens when other sensors trigger a code.
Starting with brake pads lights might be the easiest option. If the pads are good, that might be crimped and grounded brake pads wire.
Than not coincidently brake and ARS wires go in the same harness.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
Ok thanks, looks like I'll have to get that checked out, might be a bit above me to diagnose that properly. I'll see what the shop says this week and post back when I know..
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
Ended up being a simple brake light switch, I scoured benzworld for info. Got the part for $30 and replaced it myself, easy DIY. Thanks for the replies though!
 

·
Registered
Joined
·
25 Posts
Discussion Starter #9
Also! Now That I installed the new brake light switch, the front headlight is not working. I replaced the bulb and still no go. I was careful not to pull any other wires under there, but maybe I knicked something?
 
1 - 9 of 9 Posts
Top