Mercedes-Benz Forum banner

41 - 53 of 53 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #41
Just finished some minor repairs and detailing....I was able to repair the blower resistor by removing it and soldering a jumper which had broken loose. The fan motor now works on all speeds.

Detailing has brought out the real beauty of this vehicle.

I tried an experiment with the Crankshaft Position Sensor. I took an ohlm reading at outside temperature, then heated it up slowly to aprox 180 degrees and took another reading.
The reading at outside temp was 1345. The reading at 180 degrees was all over the board, then nonexistant and as it cooled down it went back to 1345. It was obvious that this thing is affected by temperature and faulty.

Tomorrow I will attempt to repair the turn signals so they cancel themselves.

Thanx again for this wonderful forum.
 

·
Premium Member
Joined
·
4,150 Posts
It is sad to see an ML so poorly treated, with faults allowed to accumulate (CEL ignored, intermittent stalling tolerated, windows not working, and finally no-start) until the truck was thought only good for salvaging parts. No doubt low-octane gas was used, resulting in the clogged EGR tube.

I can only imagine how long ago the oil was changed, and with what. MTG, do your engine a favour and put in fresh Mobil 1 0W40 at your earliest opportunity.

And enjoy your first Mercedes. :) You deserve it far more than the last owner.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #43
Crankshaft Position Sensor did the trick!!! Been driving it a week & no issues....it even gets better.....
I resyned the remotes, but this time I used the VALET KEY, which starts the vehicle. I inserted it in the ignition, turned it to position 2, turned it back to zero, removed the VALEY KEY, set it on the console, held the remote lock button, pushed the unlock button on the remote 5 times released both buttons at the same time. Then I pushed the rear hatch button. NOW BOTH REMOTES WORK. I even had one completely opened up, a real basket case....all that is inside is a computer board, the transponder chip, the button pad. You really must take your time openinmg the remote as they may break.
Pulled the boat to Flathead Lake...the MB pulls like it was meant to... better and more comfortable than anything I have to pull the boat.
Thanx again everyone, for the advice, the replies and comments....

$797 total investment....still have one window to put a motor in and possibly the console window switches.....I can live with the turn signals not canceling...besides the green turn signal arrow is big as a brick %$&&^*(()# enuf that it startled me at night driving.
Keep an eye open for me....never know where I might show up, now.
 

·
Registered
Joined
·
23 Posts
Hi, i thought that was a great idea so I checked that link to find the correct CKP part number, but they aren't free anymore. Its a subscription service for over $70.

I'm trying to buy a new CKP online because it won't start today, again, but I'm finding different ones at different prices.
I actually saved the original CKP :)grin:) when we put a new one in last year, but there's a bunch of numbers on it so I can't tell which one is the part's number.

My original is a Bosch so I'm looking for a Bosch replacement. But some say 'rear' & some say 'standard' at slightly different prices although they look the same as the one I have in hand.
I'll try other websites to see if there's clearly distinguishing descriptions.

Do guys recommend a specific website to buy parts?
 

·
Registered
Joined
·
1 Posts
If it is a clean truck you will make a lot more than $500 parting it out.
I think 43sqd is right about the previous owner knowing the AAM issue.

Than being said I am sorry you are stuck with this issue. The seats alone are worth more than $500.
I have the same year of ml30 1998 mercedes and all my suv did the same thing with my key and I went to the dealership with my ID and register for the car and vin# and I bought another key for my suv which cost 8
$80.00 three years ago and the car starter right up on the dealership yard. Now this year 2019 my battery was dead or die out and I try to jumper it with other car battery and My key lost the connect again, so I called the mercedes dealership once again and the key cost $75.00 with tax, the only thing is each time I had to carry the suv there to release the key and it start right up. Don't like the car set there just call the dealership and give them the vin# and tell them you need a key. please respond back God Bless u.
 

·
Registered
Joined
·
6,644 Posts
I have the same year of ml30 1998 mercedes and all my suv did the same thing with my key and I went to the dealership with my ID and register for the car and vin# and I bought another key for my suv which cost 8
$80.00 three years ago and the car starter right up on the dealership yard. Now this year 2019 my battery was dead or die out and I try to jumper it with other car battery and My key lost the connect again, so I called the mercedes dealership once again and the key cost $75.00 with tax, the only thing is each time I had to carry the suv there to release the key and it start right up. Don't like the car set there just call the dealership and give them the vin# and tell them you need a key. please respond back God Bless u.
So, what is the question?
 

·
Registered
Joined
·
194 Posts
I have the same year of ml30 1998 mercedes and all my suv did the same thing with my key and I went to the dealership with my ID and register for the car and vin# and I bought another key for my suv which cost 8
$80.00 three years ago and the car starter right up on the dealership yard. Now this year 2019 my battery was dead or die out and I try to jumper it with other car battery and My key lost the connect again, so I called the mercedes dealership once again and the key cost $75.00 with tax, the only thing is each time I had to carry the suv there to release the key and it start right up. Don't like the car set there just call the dealership and give them the vin# and tell them you need a key. please respond back God Bless u.
Huh? Hard to follow that...did you use Google translate?
 

·
Registered
Joined
·
2 Posts
Thanx, everyone for the leads, tests, diagrams & such, you have all been great!!!!
Since new, strange things were happening (the chime that the key is in the ignition, the doors locking on there own) I called the dealership in Missoula & I am glad I did. First, he told me that 90% of the time this is a programming issue. Second, he assured me that they can do a lot of diagnostic in 1/2 hour which is $46, and he believes he will have me on the road for less than $100. He told me to bring another individual to drive one of the vehicles home. I explained my situation and how I aquired this vehicle....he says he doesn't want me to go away a disgrunted customer to never consider a MB again.
The Mercedes-Benz will be on the trailer at the dealership at 1pm next Tuesday.
Thanx again for all the replies. When this thing runs I guarantee I will upgrade my membership.
Im having the same issue
 

·
Registered
Joined
·
2 Posts
Thank you for the reply...I ordered the Bosch from AutohausAZ as per a previous reply.
I know,DrX, I get, my wife calls it phsycotic, when I get something to work on....and especially a MB, my first.
I posted pictures somewhere...they had to be moderator approved, so maybe not up yet.
Thanx again, everyone. I'll keep you updated.
Im having the same issue as you MT miner . I have a vehicle that was purchased with a good key , ive never had the led turn on and it always started . I now have it turn on for a second or 2 then turns off when i turn it over. Im told my key needs to be reprogrammed . I bought a Valet key as this is the only key available at the moment and got home tried it and did the same thing . Not sure what else to do. My question to you is did you have to get your valet key synced with the vehicle or was it ready to go when it arrived.
 

·
Registered
Joined
·
395 Posts
Im having the same issue as you MT miner . I have a vehicle that was purchased with a good key , ive never had the led turn on and it always started . I now have it turn on for a second or 2 then turns off when i turn it over. Im told my key needs to be reprogrammed . I bought a Valet key as this is the only key available at the moment and got home tried it and did the same thing . Not sure what else to do. My question to you is did you have to get your valet key synced with the vehicle or was it ready to go when it arrived.

By any chance have you had to jump start the ML at all lately? There is a service bulletin on this and early mls, the module can get fried if connecting cables with the key in the ignition I will see if I can find it not sure which years it effects.
 

·
Premium Member
Joined
·
4,150 Posts
I bought a Valet key as this is the only key available at the moment and got home tried it and did the same thing . Not sure what else to do. My question to you is did you have to get your valet key synced with the vehicle or was it ready to go when it arrived.
Valet key doesn’t need to be synched or programmed.

If your new valet key doesn’t start the engine, you probably have a faulty immobilizer coil/module, also known as DAS ring/module. Replace with a working used one or you can buy a new one from your MB dealer.
 
41 - 53 of 53 Posts
Top