Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
1998 E320 4matic Wagon
Joined
·
1 Posts
Discussion Starter #1
Just picked up a 1998 e320 wagon a couple of weeks ago. My first Mercedes! Dents all over the driver's side and a little rot on the front fenders at the wheel wells (nothing a little tlc and elbow grease can't fix), but otherwise a pretty car. Runs strong. Getting an ABS, ESP, BAS light intermittently. The code comes up angle sensor, but I think the wheels need alignment as it pulls to the left. Consequently, the steering wheel is also turned left about 5-10 degrees and this may be tripping the angle sensor. I found that when starting the car, if I turn the wheel immediately and all the way to the right, then all the way to the left... the ABS, ESP, BAS lights go out. Usually comes back on after being on the highway for a little while. Also needs 2 front axles. One is clicking, the other is close as the boot is wide open. Will post after axles and alignment are done to see if that fixes the ABS, ESP, BAS issue. The check engine light comes on and gives me a P0400 Exhaust Gas Recirculation Flow and and P0455 Evaporative Emission System Leak Detected (Large Leak). Light goes out on it's own after a few days. The reserve light was also blinking with 3/4 of a tank of gas. After some reasearch on benzworld.org, I tried first filling the tank with premium gas and then flipping the gasket on the fuel cap. Will post again to report on the results. All in all, I am happy to be "following the star".
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
1 - 2 of 2 Posts
Top