Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,
My 1997 E230 auto ticks over slightly too slow, when you start it you have to press the accellerator or it will just turn over, when driving, when you stop or come off the accellerator, or put in neutral, it idles at below 500 rpm and judders a lot.
Does anyone have any idea what this could be?
I am lead to believe that the idle settings on these cars cannot be adjusted. Is this true???
(idle valve??? a sensor???)
thanks,
Andrew Roberts[:)]
 

·
Registered
1996 E320
Joined
·
5 Posts
Try cleaning the slide. When you take off the entire tubing that runs across the top of the engine from the air cleaner box and goes down into the manifold you will fine that you can look down right into the slide. What happens is as time passes, the slide developes it's own seal. So everytime you take your foot off the gas pedel, the slide closes and chokes the car out. The slide is made to allow just enough air into the engine at rest to keep the car idling. When the seal (carbon buildup) forms, it stops air from entering the engine at idle. Just take a clean rag and rap it around a pair of long needle-nose and spray a little gas on the rag. Once you clean it, let it dry for a few minutes and put everything back together before you start the car. If you go to the dealer , they are going to tell you you need a new slide $1800.00 [B)]. It might very well be the slide, but I suggest you try cleaning yours before changing it. Hope this helps
 

·
Registered
Joined
·
1 Posts
1997 e230

:):)I live in South Africa and also drive one of these. I followed the advise and cleaned the slide, now my car drives like a new one. Although the advice was given 6to 7 years back it worked for me. Something I picked up here with the airflow (mas) sensor, is that if you buy it from Bosch instead and cut out Benz dealers, you save 60%. Use the Bosch part no . Hope this can save someone some money. Regards Deon
 
1 - 3 of 3 Posts
Top