Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1997 Mercedes Benz E420
Joined
·
45 Posts
Discussion Starter #1
Hi,

I have a 1997 Mercedes Benz E 420

Yesterday I was driving to the store and the car drove fine.

I went inside and came out to go again and the anti skid light came on.

Also the car was jerking and got NO POWER at all... just cruised to my next destination.

no matter how far down i put the pedal i went at the same speed.

I let the car sit for a few and it drove fine all day yesterday after going to several other locations.

its 3pm now and i went to drive it around the corner and it is now doing it again, but now when it jerks it is very hard to apply the brakes and the car wants to take off like a race horse without me pushing the gas pedal.

I had to slam the brakes to stop it from crashing in my front door.

Please help... i hope it's not serious.

Sean
 

·
Registered
1997 Mercedes Benz E420
Joined
·
45 Posts
Discussion Starter #2
also when it is in park it is just popping and jerking as if it is trying to take off
 

·
Registered
1997 Mercedes Benz E420
Joined
·
45 Posts
Discussion Starter #3
Just read another post,

I turned the ASR OFF , which i didn't even know i could do... Really don't even know what it is.

When it is off the car runs just fine, which is fine with me as long as i can get to work and church.

But i am concerned about this issue.

Please Help.

Thanks guys

Sean
 

·
Registered
E320/E250 Bluetec Ford F350 6.7l
Joined
·
36,720 Posts
Sounds more like ASR (?) , not the traction. I would start with cleaning the sensors, but when you are not familiar with them -better take the car to a shop.
How old is the brake fluid?
 
1 - 5 of 5 Posts
Top