Mercedes-Benz Forum banner

21 - 34 of 34 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #21
thank you for the info i am just super confused because the power locks and the windows, turn signals stopped working and it would still start and drive until the second time i started it, then it started activating immobilizer they are related still or do i have bad ccm+immobilizer issue
 

·
Registered
Joined
·
22 Posts
Discussion Starter #22
i will try the immobilizer restart tomorrow i also think i should fully charge my battery to rule that out when it was first happening i got it to fire up about 4 times by hooking my battery to the charger
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
6,186 Posts
Get the immobilizer reset, and make sure the car starts with no alternating lights, then you can look into the other issues. One thing at a time. And get a new battery if your battery is not able to hold charge. You need 12.5V minimum from a charged battery. If your battery is not up to par, you are just wasting your time.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #25 (Edited)
because i have read a lot of posts on forums saying the ir reciever has to deactivate the alarm/immobilizer and my key fob has been missing the ir bulb and most likely more since i have owned it.
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
6,186 Posts
because i have read a lot of posts on forums saying the ir reciever has to deactivate the alarm and my key fob has been missing the ir bulb and most likely more since i have owned it.
No idea what you are saying. Yes, the key fob, when it works, locks/unlocks the doors, and when locked, the alarm is activated., and unlocked deactivated. It also deactivates the immobilizer. If you unlock a door with a dead battery, as the alarms is still armed when the power is restored, the car will not start, so you need to reset the immo. You can then synch your key fob electronics once the car is started.
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
6,186 Posts
The 1996 has problems with biodegradable wiring. One of the common issues is the crankshaft position sensor wiring being damaged. It could be the reason why the car is not starting. The best way to find out is to have the car modules scanned by a mechanic who has the proper scanner like Snap On , MB SDS, Autel, etc. with access to the 38 pin diagnostic port under the hood at the drivers side.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #32
after charging the battery fully the alternating red and green lights dont flash on position 2 but it still only cranks
 

·
Registered
Joined
·
68 Posts
any lights that come up are more than likely temporarily related to the car battery being disconnected. these cars so so finicky its like booting an old laptop every time you loose battery power.

did you have a chance to inspect the CPS wiring? it is easy to find with a flashlight. (picture is a deisel but same location, the gas enginge has only one, position 29)

 
21 - 34 of 34 Posts
Top