Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
1994 E420 with ASR

Greetings Everyone!

My 94 E420 is at 183K (I bought it new originally). At 182K, the vehicle began missing badly at all RPMs, both cold and hot. The mechanic replaced the degraded engine harness. However, after the car sat idle for a day, it ran rough again until traveling approximately 10-12 miles distance. Then it ran okay except for occasional skipping at idle. The mechanic next changed the mass meter(mass sensor). That was over $500 wasted (no improvement whatsoever). Now he suggests changing the ASR harness ($1000). However, neither the "Check Engine" light, nor the ASR light presently go on, and, REPEATEDLY, the car has demonstrated the same pattern for 5 weeks : Rough running and stumbling the next day until it covers 10-12 miles. Then runs okay (even after shutdown for several hours), except for frequent skips while idling. The more days it sits idle without running, the worse it runs/stumbles until 10-12 milles distance is covered. Any thoughts? The coils were swapped out and weren't the problem. What stymies me is why it needs both warming up and 10-12 miles distance covered before the lack of throttle response dissipates. I should think if it was the ASR harness, the problem would be constant...?
 

·
Registered
'95 E300 DIESEL, '91 600SEL, '92 600SEL
Joined
·
17,400 Posts
Was the ETA (electronic throttle actuator) replaced at the time the harness was replaced??

If not, it is the most likely source for the stumbling/rough running. The ETA suffers from the same wiring issues as the harness. Also, make sure the OVP relay was replaced as well.
 

·
Registered
Joined
·
224 Posts
W124.034/036 cars don't have OPV's like the early cars.

Throwing parts at things gets expensive... he needs to DIAGNOSIS the problem.
Clear all the codes, then drive it and read the codes. Great cars, but pricy with repairs. If you read on this site much- you'll be aware of M119 problems(timing chain and guides can be fatal to the motor).

What color code combo do you have??


Michael

94' white 420e.
 

·
Registered
2013 E350 sedan, 2013 E350 cab, 1993 400E sold,1999 ML320
Joined
·
2,436 Posts
throttle wiring wont throw any tangeble codes, just gotta open it up and look. If you have caps and rototrs i suggest cleaning or replacing as arching makes them get dirty quick.
 
1 - 5 of 5 Posts
Top