Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4,949 Posts
Discussion Starter #1
Hi All,
i'm looking for another Benz for my bro, yesterday i looked at a 1994 C280 with 156K, the car looks clean inside and out.
But i noticed few things that i need some advice from the W202 experts here.

1. Next to the Thermostat housing cover i saw a bunch of wires wrapped in plastic tape, is this the wiring harness but was just fixed instaed of replaced?

2. while driving the car i noticed like a back fire ( like a blow coming out of the muffler) then the car drives fine. also it revs very well in P position.

3. while testing the AC i found it worked fine, but when i put the heater ON i noticed that only heat is coming out of the passenger side only, the driver side has only outside air, even the center vent right half was giving heat and the left half is giving outside air only. also the deforst was not giving hot air.
what could this be?

thanks in advance. :thumbsup:
 

·
Registered
Joined
·
1,944 Posts
3. Could be a stuck or bad duo-valve. It is pretty common for them to be going bad at this age. When you pay your qualified indy Mercedes guy to do a prepurchase inspection, make sure to talk with him about the problem.
 

·
Registered
Joined
·
1 Posts
Hi All,
i'm looking for another Benz for my bro, yesterday i looked at a 1994 C280 with 156K, the car looks clean inside and out.
But i noticed few things that i need some advice from the W202 experts here.

1. Next to the Thermostat housing cover i saw a bunch of wires wrapped in plastic tape, is this the wiring harness but was just fixed instaed of replaced?

2. while driving the car i noticed like a back fire ( like a blow coming out of the muffler) then the car drives fine. also it revs very well in P position.

3. while testing the AC i found it worked fine, but when i put the heater ON i noticed that only heat is coming out of the passenger side only, the driver side has only outside air, even the center vent right half was giving heat and the left half is giving outside air only. also the deforst was not giving hot air.
what could this be?

thanks in advance. 👍
i HAVE A 1994 C280 W202 AND I WISH THAT I NEVER BUT IT PROBLEMS STAY OUT
 

·
Registered
Joined
·
1,559 Posts
Hi All,
i'm looking for another Benz for my bro, yesterday i looked at a 1994 C280 with 156K, the car looks clean inside and out.
But i noticed few things that i need some advice from the W202 experts here.

1. Next to the Thermostat housing cover i saw a bunch of wires wrapped in plastic tape, is this the wiring harness but was just fixed instaed of replaced?

2. while driving the car i noticed like a back fire ( like a blow coming out of the muffler) then the car drives fine. also it revs very well in P position.

3. while testing the AC i found it worked fine, but when i put the heater ON i noticed that only heat is coming out of the passenger side only, the driver side has only outside air, even the center vent right half was giving heat and the left half is giving outside air only. also the deforst was not giving hot air.
what could this be?

thanks in advance. 👍
1. photos would be helpful

2. do you have use of a decent scanner. Scan and post any saved error codes. This is a 1994, so you may need to scan from the 38pin under the hood.
"revving well" in P isnt a helpful indicator - you need to take it for a test drive in gear.

3. sticky duovalves - diy repair kit - quite easy todo with plenty of how-to youtube videos.
 

·
Registered
Joined
·
4,949 Posts
Discussion Starter #7
Thanks mate, this thread is 12 yrs old, we didnt buy any W202, we ended up buying a W124 then sold it then bought another W210 and a W140.
 
1 - 7 of 7 Posts
Top