Mercedes-Benz Forum banner
1 - 7 of 7 Posts

·
Registered
1997 E420 152 k on the clock
Joined
·
22 Posts
Discussion Starter · #1 ·
Ok the car died and would not restart. The harness that runs to the MAF was melted. I decided to change the harness today it took me about 6 hours total. Was not the worst job I have ever done but was no fun either. I could have routed it better but what the heck the engineers that designed it probably figured that it would never need replacing. Now I have no spark and no fuel. How do I test the ECM?
 

·
Registered
96' C220
Joined
·
1,275 Posts
ECU

I've heard of Guys buying them off of e-bay and swapping them out. Have you tried starting the car with the MAF unhooked? It should run in default mode unplugged. You probably toasted your original one with the wiring problem.

Good Luck!:thumbsup:

C as in 220
 

·
Registered
1995 C220 102k
Joined
·
588 Posts

·
Registered
1995 C220 102k
Joined
·
588 Posts
I've heard of Guys buying them off of e-bay and swapping them out. Have you tried starting the car with the MAF unhooked? It should run in default mode unplugged. You probably toasted your original one with the wiring problem.

Good Luck!:thumbsup:

C as in 220
GOOD POINT CJ!!! check to see if it will run with the MAF unplugged first!:thumbsup:
 

·
W201, W202, W203, W204, W205 Moderator
Amethyst 2001 C320 with 351,000 miles
Joined
·
1,737 Posts
It does indeed sound like a toasted ECM, but have you had any luck checking for voltage prior to the coil packs?
 

·
Registered
1997 E420 152 k on the clock
Joined
·
22 Posts
Discussion Starter · #6 ·
Car is fixed. The problem was the overload protection relay part #0005406745. Car is now running. Thanks for all the help.
 

·
Registered
Joined
·
1 Posts
hello all,
can anyone tell me if replace my ecm on a 1994 c220 with a used or rebuilt ecm,do i have to program the replacemebt ecm?
 
1 - 7 of 7 Posts
Top