Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2002 ML320
Joined
·
7 Posts
Discussion Starter #1
Hi all, I am hopeing that some has some ideas on this problem. A couple of days ago I used the car and roof and windows were all working normally. Parked overnight and the following morning the car started normally but the drivers (left) side window is inoperative. Also the roof only partially operates. The rear hatch opens, the back locks unlatch and the back section of the roof raises. And that is it. No further action. It will all then reverse it's action. Obviously something is telling it the window is still up or something like that. A plug fallen off, a relay not working, surely something really simple but what?
Any suggestions would be gratefully recieved as I and the car are in Cambodia where there is a significant shortage of competant mechanics.
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,116 Posts
Is you battery in good shape and are you operating the roof with the engine running ?
 

·
Registered
Mercedes 500 SL from 1991, Mercedes 190 Rosso, A160 CDI, A160, W140 300SD, W108 280SE 4.5
Joined
·
82 Posts
I have this same porblem I know yhat i must buy new control modul for roof. Can sombody help me. or have roof modul for sell???
 

·
Registered
2002 ML320
Joined
·
7 Posts
Discussion Starter #5
Roof and window problem solved

hanks everyone for your suggestions. We solved the problem it was a connector on the left hand side of the boot that had come adrift. Pluged it back in and all back to normal. Suggest checking before replacing module.
Cheers.:)
 
1 - 5 of 5 Posts
Top