Mercedes-Benz Forum banner

1993 Mercedes 190e 2.6 Transmission Problem

6527 Views 2 Replies 3 Participants Last post by  babybenz
Hello, I have a 1993 Mercedes 190e 2.6 in the United States, and I thought I would see if anyone here could enlighten me as to possible explanations or fixes for my current problems:

My car has 149,000 miles or 239,000 km with an automatic transmission

1) Just recently my car is having a problem accelerating from a standstill. When I push the accelerator pedal, the car will hesitate before speeding up. What will happen is the RPM meter will climb to about 1500-2000 RPM's before moving forward, but then it will catch the 1st gear and will accelerate like normal. Every other gear works fine, it is only when the car tries to start from a standstill in 1st gear that the transmission does not seem to engage the first gear. I am very worried that I will need to replace the transmission, so hopefully this will not be the case.

2) I am also having a starting problem. The first start every day after sitting in my garage over night is 100% fine, but as the day goes on, like after having been driving around or leaving the car outside in very warm/hot temperatures, the starting becomes very bad. When trying to ignite, the car will act like it will start, like the RPM's will climb, but then stop and the RPM's drop and the starter will continually turn over for about 5 seconds before starting up fully. It seems to help when I push the accelerator pedal in. This problem is not as bad in the winter months, but the worst during the summer months. Two different service departments have been unable to eleviate this problem. Here are some things they have tried:

Replace O2 sensor, replace fuel injector nozzles, replace distributor cap and rotor.

The car will always start, so I have not made a huge deal about getting this repaired, but as an annoyance factor, I am tired of it being a problem. I would be so greatful if anyone can help me on these problems! Thanks for your time!

Tom
  • Like
Reactions: fahri Bega
1 - 3 of 3 Posts

· Registered
Joined
·
53 Posts
If I were you, I'd take my problems to the 190revolution.net forums. There are dozens of p...

If I were you, I'd take my problems to the 190revolution.net forums. There are dozens of people there who can solve your problem and you'll get a reply in a matter of minutes.

Great forum for the 190E and 190D [8D]
 

· Registered
1991 190e 1.8 Euro
Joined
·
15 Posts
Warm hardstarts...

Warm hardstarts?

Probable suspects :

1 Fuel accumulator
2 Fuel pump check valve

Cheers.
[:D]
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top