Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
The AC on this car cycles on and off.
I connected a gauge manifold to it and the high pressure side pressure rises and then the ac compressor clicks off. Then the pressure falls and the compressor clicks off again.
Obviously some pressure switch preventing excessive pressures on the high side

As far as I recall, the high side carries gas from compressor to the condensor to be made into liquid and then to the evaporator to be passed thru the expansion valve and be converted into gas once again-cooling the evaporator and the interior of the car in the process. The low side carries this hot gas to the compressor.

So I think something in the high side is rectricted. Could be the expansion valve or the condensor or the filter.

Anyone with similar problems?
 

·
Registered
Current 1992 - 500SEL, W124 - 1989 230E (sold)
Joined
·
1,387 Posts
I've had same problem for last 2 years and nobody knows how to fix it...
symptoms are: compressor is cycling on and off but very unreliably, almost whenever it feels like it so i dont get consistent AC at all...
 

·
Premium Member
2008 E 320 Bluetec (ELEGANCE) 2005 CLK500 (avant-garde)
Joined
·
1,928 Posts
Check evaporator temp sensor and engine temp sensor.

Run the codes first-will save you a lot of headaches down the road!

Some Independent mechanics who don't know the W140 well fail to do this and approach it as if it were a W126 or earlier. The W140 is a VERY complex beast!

Run the codes!
 
1 - 5 of 5 Posts
Top