Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi guys, I just picked up a 92 300e with 244,000 kms (147,000 miles) last week
in what I thought was a reasonable deal $1888 cad. The brand new oem MB wheels, tires what got me.

Problems inclu. with reverse and one wheel turning faster because the e-brake cable catches.

More notably though,
I was driving around sunday when the car started to smoke with the sweet coolant smell. Flushing the radiator and all that aside I never noticed because the indicators never game me a heads up.

I also bought the car knowing the drivers window needed to be helped to be forced down which I figured to be minor ( maybe sitting incorrectly, just needed an adjustment)
However, since the r/ right passengers window has failed and has 4 inch gap it wil refuse to go up. the headlight bulb just went on me. And now my drivers seat chair after fiddling around the movements is stuck in an uncomofrtbale sleeping position.
any direction would be appreciated.

This is my first car, i've always wanted an MB, keep me in good faith will you!
 

·
Registered
2008 E350 4M, 2016 Audi Allroad, 2019 Audi Q5
Joined
·
5,447 Posts
What is the problem with reverse?

....I'm probably going to bet the bringer of bad news, but most likely you are looking at a removal and rebuild if it is slow engaging, or does not engage. Common, but expensive and a real PIA.
 

·
Registered
2013 E350 sedan, 2013 E350 cab, 1993 400E sold,1999 ML320
Joined
·
2,436 Posts
Window not moving id bet is the regulator gone bad. If you have coolant coming out the exhaust may be a head gasket which isnt good. Do a search on switch take apart or cleaning as it may just be that. Do a search on reverese but I agree with ps2cho.


18 year old MB maybe not the best bet for a first car. Nice and safe but probably need alot of help if it was cheap.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Hey guys, thanks for the replies.
Well to settle the debate on whether its trustworthy, the previous owner was pretty straightforward. (and loaded.. bentley, 500 hp skyline, sending his kid to med school in princeton) He just had no need for it.
He replaced the cable 4 years ago when his son was susing it he kept using the e-brake. nervous bugger was told not to because of problems with cables.. catching? apparently common in mbs?
We jacked up the rear and span in reverse. Its not a tranny problem. You can tell one wheel catches at first and spins off timing with the other.

I can reverse, just not strongly at first, or uphill really. So p2scho it engages, would that be a gear problem. Forget to mention, this is an automatic (so rare I know ha)

Im thinking the smoke may be from the heatercore...
honestly I dont know if It is for certain from overheating or the goopy coolant that was there. I topped it with some water to get me home and the smoking disappeared. (i dont know how I missed that in the 1st place)
no echaust tho macdrone.
looks like im not getitng new head anytime soon :(

just replaced bulb. step 1 in proabbly a million to see if this car is a lemon.
ill update again after I rotate fuses, clean switches on your advice. take apart the door to see the whole regulator problem
Any advice on what keywords to use for reverse problem (cable problem) cause Im getting very little feedback.

Anyways, thanks so much guys.
 

·
Premium Member
About a dozen 1988, 1989, 1990, and 1991 sedans, wagons, 4Matics and 1 coupe
Joined
·
5,466 Posts
I'm sorry but there's just no way to sugar coat this:

Buying an 18 or 19 YO Benz with almost 150k miles on it that hasn't been kept up to snuff (maintained a repaired) is a surefire way to drive you nuts and deplete your bank account.

While the 124 is a truly great and solid piece of engineering, letting maintenance and repairs slide will come back to bite you. Or the guy who you sell the car to after you get frustrated. At the moment it sounds like you're the guy who just bought the car.

If you're commited to getting things straightened out over a period of weeks or months, great, and you'll be rewarded with a super car. But don't expect to solve all the problems in a day or two because even things like removing a door trim panel is a bit tricky and it is *so* easy to break things if you yank or pry.

So there, that was my pep talk.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
p.s.
ps2cho your 260e is so f'in clean. we got the same colorway and I bought the 92 cause I thought the 300e was so damn strong, reliable and hey they dont look bad either.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
augapfel, I appreciate your honesty however this site is riddled with cars far older than this. The maintainence records all were flawless. jsut replaced cat/ o2 sensor.
The guy had owned it since 1994. I just bought it under a week ago. Consisdering I could part it out at almost the asking price, it seems reasonable.
The problems have mounted as I bought it. First the r/rear window failing, the coolant oversight, the headlight bulb, then the seat.
Seeing as I know little about MBs im just looking for help.
And perhaps ill hold off taking a look at the regulator. I just have the seat in an awk driving position. Is there an override?
 

·
Registered
2008 E350 4M, 2016 Audi Allroad, 2019 Audi Q5
Joined
·
5,447 Posts
As long as you are sure it physically engages quickly then it could be a diff problem possibly. The problem lies in the B3 bands/disks. They wear and it ends up no longer gripping to allow the car into reverse. At first it shows signs such as a delay going into reverse, then progresses slowly into no longer going into reverse at all. It happens to all 722.3/.4 transmissions, but other than the reverse issue, the tranny is pretty bulletproof. Fluid changes are KEY to this though.

Check your flex disk for any holes around the bolts. Common wear item.

As for the windows, the rear windows have the motor and regulator as one whole item, so more than likely the cable has snapped, or has come off the runner. You'll probably need to replace it. Not too difficult, but a little messy.
Windows do not work/move at W124-Zone.com – A Mercedes W124 Resource Site
 

·
Registered
300E 1992
Joined
·
2 Posts
We have been experiencing horrible windy rains. I was driving and my radio started having an intermittent crackle. The noise coming from over the speaker. I parked it after shopping and now, it does not even click after turning the key no lights anywhere. Charged battery to full charge. I have been replacing every fuse hoping to get the dash board working clock etc. Could my key switch have quit working or light switch? I can not open trunk to disconnect antenna in case it is waterlogged??? The CRACKLE CAME FROM THE SPEAKER OVER THE LIGHT SWITCHES for parking lights headlights. Humidity plays havoc with those aluminum fuses, but is hard to find the copper ones in every auto parts. has anyone else had similiar problems? My benz is 1992 300e and I have been driving for nearly three years trouble free and very dependable.
 

·
Registered
1984 300dt 1985 300 dt 1992 300e just added another 92 300e 1994 e420 1993 300te 4matic
Joined
·
2,506 Posts
We have been experiencing horrible windy rains. I was driving and my radio started having an intermittent crackle. The noise coming from over the speaker. I parked it after shopping and now, it does not even click after turning the key no lights anywhere. Charged battery to full charge. I have been replacing every fuse hoping to get the dash board working clock etc. Could my key switch have quit working or light switch? I can not open trunk to disconnect antenna in case it is waterlogged??? The CRACKLE CAME FROM THE SPEAKER OVER THE LIGHT SWITCHES for parking lights headlights. Humidity plays havoc with those aluminum fuses, but is hard to find the copper ones in every auto parts. has anyone else had similiar problems? My benz is 1992 300e and I have been driving for nearly three years trouble free and very dependable.
...you might want to fill out your profile and start a thread for this issue youre having. this thread is 5 years old.

ebay for copper fuses. i would check the voltage at the battery while the car is running in order to read the voltage regulator output. they wear down causing the battery not to charge and when that happens systems start to shut down. radio, heater, wipers, nothing will work thats electrical with a bad voltage reg. if thats the issue, ez and inexpensive fix.
 
1 - 10 of 10 Posts
Top