Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
My daughter's 190E started doing something weird 2 days ago. When you lock the drivers door from the outside with your key, the central locking system pulls all the doors locked as normal....But about 2-4 minutes later, they all rise and unlock the car!

It also does the same when locking the car from the trunk lock. First all 4 plungers descend - then a couple of mminnutes later UP THEY come!

Basically, it is impossible to lock the car any more...

Any ideas?

Thanks,

Rob
 

·
Registered
1985 190E 2.3 (Sold)
Joined
·
210 Posts
Sounds like a vacuum problem to me. Inspect the hoses that go to the vacuum pump, which is located under the rear seat on the passengers side. Make sure they are tightly connected and there is no leaks.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Thanks Dan.

After thinking more about this "automatic unlocking" behavior, the only thing I could imagine is a defective pump that somehow changes from vacuum mode to pressure mode on it's own accord. There is not a microprocessor that controls the pump - just the key lock switches.

I went ahead and ordered a replacement Vacuum Pump from Autohaus Arizona for $161.00 - MUCH cheaper than ANY other site online. I will check the connections and then replace the pump while I'm down there.

I'll report back with my weekend project results!

Rob
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Success! I received the door lock pump from Autohaus AZ and replaced it last week and all has been fine since then. The guy (Tom) at Autohaus AZ was very helpful in explaining why the pump he sells goes for $161 while the other places sell them for about $275! The one I received from them was a Hella (made in Germany) and was a perfect replacement. The original was a Bosch.

Anyway, good fix and I recommend Autohaus AZ 110%.

Rob
 
1 - 4 of 4 Posts
Top