Mercedes-Benz Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
I just purchased a beautiful 1990 560 SEL and everything works perfect in it except the front power seats for some reason. I thought at first it was just a fuse, but it doesnt look like the fuse is blown. Any other ideas?
 

·
Registered
1982 280 se aut. ecc. - sold
Joined
·
1,607 Posts
Welcome
Please (re)read the "welcome to the forum" sticky.
It will tell you how to fill out your profile and why. It will also tell you how to search this forum.

gr J
 

·
Registered
1982 280 se aut. ecc. - sold
Joined
·
1,607 Posts
Fuses that look good may be bad after all. You could also swap the relais (Icecubes) around.

gr J
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Ok,

So I have decided that more then likely it is not the switched gummed up (I am sure they could use cleaning though) because the telescoping steering wheel does not work along with both the front seats. I have been told they they are on the same power supply.

So …. This is what I have done:

--Changed all the fuses (A,B,C and D) for the seats.

--Tried moving the switches with the door open

--Sprayed a bit of cleaner into the switched to see if they budge

None of them worked.

Since I am about positive it is the power supply, what other options do I have?

I have heard “relays” mentioned … are these the boxes in the fuse box, and how can I figure out if this may be the problem?

Also, is there any other things that could make this happen?

Everything works on the car except the power front seats and the telescoping steering wheel.

Thanks in advance for your help!

Joey
 

·
Registered
1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Joined
·
1,376 Posts
did you fix it, i have the same issues?
 

·
Registered
1987 420 SEL
Joined
·
2,097 Posts
Try this...Put your ears at the bottom of the seat and push the seat buttons. See if you can hear the seat motors running. I have a problem with my seat back coming forward. I have to pull on it while pressing the button and then it will move.
 

·
Registered
1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Joined
·
1,376 Posts
na man the whole side is dead
 

·
Registered
Mercedes-Benz 560SEL mod 91,MB 560SEL mod 90
Joined
·
500 Posts
I have similar problem in my car just happened. When I had one electric fan burnt with its relay, I replaced the fan and relay. Since then, I had the front seat and the windows do not open or close either. Up to now, I did not fix it.
Regarding the fuse box, how do I diffrentiate between the fan electric relay and other relays?
 

·
Registered
2001 ML430, 1983 300SD, 2008 GL450
Joined
·
909 Posts
Look underneath the seat and make sure that the cables are plugged in. Then pull the switch and make sure that it is receiving power. You can test the switch functions at the same time.
 

·
Registered
1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Joined
·
1,376 Posts
what if the switch isnt getting power, my seat speakers, door lights and seat belt lights arnt working
 

·
Registered
2001 ML430, 1983 300SD, 2008 GL450
Joined
·
909 Posts
Then the wires going into the door are broken. Perfectly normal with any car after 10+ years of use. Pulling the door panel, the side panel by the door hinges, and the carpet will give you enough access to troubleshoot everything.
 

·
Registered
1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Joined
·
1,376 Posts
well i did that and didnt see anything, is there anyway to jump start it so i can change the position of the seat? or could it be a relay
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,498 Posts
Nine times out of ten the wires are broken inside the door gromments (the accordion looking rubbers between the door and the body. These flex every time the door is opened and that is where they break.

Have you taken the switches out and cleaned them???...NOT just the spray cleaner as that will only get the crud out and not do anything to polish the contacts! Thes contacts burn over time and are black when taken apart the first time in 20 something years.

Clean the contacts on the door puddle assist lights too. Trace the two wires to the connector on the door frame.

Seat belt light? Possibly there is crud in the seat belt connector between the seat and the console or it is disconnected under the seat???
 

·
Registered
1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Joined
·
1,376 Posts
thanks for the input,

yes i have taken out the switch and properly cleaned it, as well removed the door panel and carpet parts, how would i check the wires between the doors?

The worsed part about the seat issue though is that it is to far forward to remove the front two screws...
 

·
CH4S Admin , Outstanding Contributor
1985 500SEC, 1991 190E 2.6.
Joined
·
43,826 Posts
I have similar problem in my car just happened. When I had one electric fan burnt with its relay, I replaced the fan and relay. Since then, I had the front seat and the windows do not open or close either. Up to now, I did not fix it.
Regarding the fuse box, how do I diffrentiate between the fan electric relay and other relays?
Please re visit the 'Welcome to the Forum' announcement / tutorial sticky on top re search.
I remember 420 SE posting the fuse and relay designations recently.
Cheers
 

·
Registered
Mercedes-Benz 560SEL mod 91,MB 560SEL mod 90
Joined
·
500 Posts
Look underneath the seat and make sure that the cables are plugged in. Then pull the switch and make sure that it is receiving power. You can test the switch functions at the same time.
I had not only the front seat but the windows as well.
What is the relation between the front seats and the windows?
 

·
Registered
1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Joined
·
1,376 Posts
wow, well i have the same issues exactly, whole front right dead, luckily the PO was able to switch the drivers window switch with the drives passenger switch so i can use my drivers window. The back window wont go down but i can live with that.

- does your drivers speaker not work to?
 

·
Registered
Mercedes-Benz 560SEL mod 91,MB 560SEL mod 90
Joined
·
500 Posts
I have similar problem in my car just happened. When I had one electric fan burnt with its relay, I replaced the fan and relay. Since then, I had the front seat and the windows do not open or close either. Up to now, I did not fix it.
Regarding the fuse box, how do I diffrentiate between the fan electric relay and other relays?
When the Electrician replaced the burnt fan and its relay, He misplaced the H and F relays. The Windows and front seats relay has 6pins while the other relay has only 5pins and that was why there was no power feeding the seats and windows. By looking to the other car fuse box, I saw different arrangment of relays in both fuse boxes. I corrected the one having the problem with the other one and I was done. Below there are two pic of the relays. The first one is the incorrect pic and you can see the 5pins green relay is placed in the position of the windows and front seats the yellow relay 6pins. The second pic. is the correct relay positions.
 

Attachments

·
Registered
1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Joined
·
1,376 Posts
it may not or may not matter but all my relays are silver.. is there any difference in your color ones?
 
1 - 20 of 30 Posts
Top