Mercedes-Benz Forum banner

1 - 15 of 15 Posts

·
Registered
1990 300sl =1976 450sl = 1998 e320 = 1999 c230 k =1999 corvette conv = 1996 corvette coupe
Joined
·
19 Posts
Discussion Starter #1
my 1990 300sl is slow , when i give it gas it just not have any power - it is like it is not geting the fuel and also the transmission does not down shift into passing gear . i would appreciate any help i have never had a 300 sl but do have a 450sl -e320 -c230k-300sel--this 300sl is sick .please help . thanks sammy in knoxville tn
 

·
Registered
1990 300sl =1976 450sl = 1998 e320 = 1999 c230 k =1999 corvette conv = 1996 corvette coupe
Joined
·
19 Posts
Discussion Starter #3
slow sl

soory to be dumb but i do not know what you talking about. thanks
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,004 Posts
Something is wrong and your car is trying to protect itself from serious damage by limiting the engine speed, and the transmission etc. Yes, our MB are that smart, while other cars would just shut itself down, ours let you 'limp' home with it.
You will need to have a diagnostic scan to find out what's wrong.
 

·
Registered
1990 300sl =1976 450sl = 1998 e320 = 1999 c230 k =1999 corvette conv = 1996 corvette coupe
Joined
·
19 Posts
Discussion Starter #5
slow 300sl

will do . thank you
 

·
Outstanding Contributor
'03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Joined
·
4,234 Posts
A U.S. 1990 300SL does not have a limp mode for either its throttle or transmission.

The first thing I would probably do is check the condition of the spark plugs and their spark gap. If the car has always lacked power since you owned it, then I would also check compression. Next I would check the fuel mixture by measuring the current to the fuel distributor EHA and also viewing the feedback signal from the oxygen sensor. You need a basic electronic multimeter to perform the measurements, and this article details the procedures: PeachPartsWiki: Mercedes-Benz Driveability.
 

·
Registered
Joined
·
328 Posts
I would also check your cats. I used to have a 600sl where the cats broke up and blocked the exhaust. The car had no power and would not downshift properly. I did a quick fix by getting the mechanic to cut open the cats and remove the insides then weld the boxes again. instant power but slightly noisier. obviously it's a temporary fix until my new exhaust arrived because the car will not pass emissions testing like that.

WOOOOO HOOOOOO! POST NUMBER 300 FOR ME :D
 

·
Registered
1990 300sl =1976 450sl = 1998 e320 = 1999 c230 k =1999 corvette conv = 1996 corvette coupe
Joined
·
19 Posts
Discussion Starter #8
slow 300sl

thanks friends, i took the car to the have the cat checked but he man their just felt of the tail pipe and said it was running rich and told me he thought it was the ox s -he never checked the cat=== i will check the plugs and start from their = as far as the cat it gets hot and smells after a 20 mile trip . thanks again i need all the help i can get ... sammy in tn
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,004 Posts
Sl man
Sorry about the mis-information of limp mode as I did not see in your profile what year car you have. BobTerry is the expert for our cars, so if there are ANY conflicting advices, his is most likely the correct ones.
 

·
Registered
2000 Obsidian Black Metallic Mercedes SL 320 V6
Joined
·
4,527 Posts
sl man welcome aboard in our big and friendly international family. To help us help you in the best and quickest possible way you should fill your profile with your car year and location.

Good luck on your problem.

Cheers.
 

·
Registered
1990 300sl =1976 450sl = 1998 e320 = 1999 c230 k =1999 corvette conv = 1996 corvette coupe
Joined
·
19 Posts
Discussion Starter #11
i will fill out the profile. thanks again

sl man welcome aboard in our big and friendly international family. To help us help you in the best and quickest possible way you should fill your profile with your car year and location.

Good luck on your problem.

Cheers.
will do and thanks to everyone
 

·
Registered
1990 300sl =1976 450sl = 1998 e320 = 1999 c230 k =1999 corvette conv = 1996 corvette coupe
Joined
·
19 Posts
Discussion Starter #13
slow 300sl

thanks friends, i changed the spark plugs and the car runs great , stillruns rich - will work on that problem later . again thanks sammy
 

·
Premium Member
95 SL500, K&N, NEOKEN Ported TB, Custom Intake, RENNtech Sport Exhaust, AMG I Monoblocks
Joined
·
10,980 Posts
thanks friends, i changed the spark plugs and the car runs great , stillruns rich - will work on that problem later . again thanks sammy
Hi Sammy, regarding your 1990 SL320 running rich, most likely the O2 sensors need replacement.

Best Regards.
 

·
Registered
1990 300sl =1976 450sl = 1998 e320 = 1999 c230 k =1999 corvette conv = 1996 corvette coupe
Joined
·
19 Posts
Discussion Starter #15
slow sl

i will ckeck them . again thanks alot.... sammy in tennessee
 
1 - 15 of 15 Posts
Top