Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Hello, perhaps some of you know this. What controlls the air pump to cycle on and off. Mine turns on for a half second when the car is fully warmed up
(80+) and I get a check engine light flash(no code) and the stumble I've been chasing for awhile. Can happen 5 times in a row, or once and then miles later do it again. This is driving my crazy and help would be great.
 

·
Registered
Joined
·
13,337 Posts
why not just unplug the bloody thing? Likely throws your O2 sensor readings all to hell...thus the CEL and subsequent lack of lambda input.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
I have unplugged it and it still happens. I'm just looking for clues why it is turning on at full temp and if that relates to my problem. I have since last night found the conditions that must exist for it to turn on. I thought I was onto something with the coolant temp sensor being out of spec. I put a new one in and the car ran great last night but today started doing it again. I ohm tested the "new" sensor and it also gave me a weird reading. One set of [email protected] and the other @325ohms. Should be the same right. So I believe this one is faulty and have a new one tomarrow. The other possibility is the CIS-controll unit is bad but I'm not ready to rule that totally in yet, not untill I get a proper reading temp sensor in the motor.
 

·
Registered
Joined
·
13,337 Posts
yes, they should agree b/w each set.. who makes the new sensor?

I'd also wonder if your KE unit is freaking out... if you have anyone around w/ any year 560 or even a 420 you can swap KE's easy enough for testing.

jono
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
Hi jono, I wondered about my KE-unit also. Is there a ohm test or volt test I can do to see if it is in spec. I don't have any friends with parts I could try out.
 

·
Registered
Joined
·
13,337 Posts
there are some tests, but nothing spectacular that I've found for pin to pin'ing a KE.. I've always got a stack of spares on the shelf...sooo... You have any bone yards out by you? Ya'll get a LOT of late model 126's out there, I bet you could find a V8 KE for pretty cheap..prolly pick up a bunch of other spare bits while you are @ it..;-)

We do have a Large # of west coast members here, perhaps one lives close by..??

jono
 
1 - 6 of 6 Posts
Top