Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Ok, so I got this mercadices for $500 from a nebor and he said that some one drove it and wanted to clean it up a bit so the washed the motor with water when it was still warm then it would no longer run. We took it home and tried to fix it so we went to the U Pull it and got a distributor and a new coil(car had no spark). After putting on those parts it wouldn't start . Anyway we started researching and a found a few threads on here and got a EZL(ignition control module) on ebay. Got it a few days later and boom it started but didn't want to run kept running rough and wouldn't idle. So, the guy that sold it to us told us to take it on the freeway to reset the EZL so we did got it home and it was running VERY good after letting it sit over night it wouldn't start so we cleaned every connection up still no start. we took a break with it as it seemed pointless. I took out the spark plugs and cleaned them they were a little oily and put the orignal coil and distributor it it and it started up again we took it on the freeway after letting it run for about 25minutes and it sounded as if it was missing like all plugs were not sparking. we get home after about 40 mins on the free way and it starts to idle as it should for about 200 feet then it dies. Now it starts but its really hard to start I recorded a video of how it starts and dies and wanted to know if there is anything I missed.
BTW when testing the sparks they were blue dont know if that matters

1988 Mercadices benz 300E dies while idle - YouTube
 
1 - 5 of 5 Posts
Top