Mercedes-Benz Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi there
My 1988 300sel new radio antenna was working a while back and now it has stopped working
The radio works fine. The antenna no longer works , also the interior lights heated seats have stopped working.
I replaced with new fuses but still not working
Can some please recommend any subjections
 

· Moderator
1987 & 1991 C126
Joined
·
6,804 Posts
Hi there
My 1988 300sel new radio antenna was working a while back and now it has stopped working
The radio works fine. The antenna no longer works , also the interior lights heated seats have stopped working.
I replaced with new fuses but still not working
Can some please recommend any subjections
Hi Steve,

I have been looking for common power & grounding points for your issues & apparently found one for both the power antenna & the courtesy lights.
It would be easier if it were just the antenna switch accidentally set to off position... I digress..

You'll see the circuit path from fuse 15 feed through connector X18 where the related circuit paths branch to feed both the courtesy lamps & trunk lamp & the power antenna..
[Earlier variant & differing radio systems all share this wiring scheme BTW.]

Perhaps this will bear fruit for you..
Rectangle Font Parallel Schematic Diagram


Event Circle Pattern Electric blue Font


Motor vehicle Font Art Auto part Line art



MBL

In addition, might you please complete your profile to reflect both year & model of your car?
Its really helpful going forwards..
 

· Registered
50 years of MB
Joined
·
5,251 Posts
I think the heated seats should have a small fuse box on the left inner fender.

The antennae you can apply 12v to terminals and see if it still works.
 

· Registered
1989 300SE 247k+ miles
Joined
·
4,606 Posts
"New radio antennae" can unfortunately mean a lot of things.

The first place to look, as MBL suggests, is the antennae control switch on the dashboard. If it is locked down (as it is designed to do), the antennae will stay down.

After this, with the key in position 2 of the ignition, turn on the stereo head unit. Do you hear the antennae motor working? If so, you need to look at the mast, its gears, and the motor and its internal gears.

If the motor is not activating, look at electrical connections.

These will help you determine if the cause for your problems is shared or not.

Just an fyi, my power antennae still goes up and down even though my antennae is unplugged from the stereo head unit.
 
1 - 5 of 5 Posts
Top