Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
So I let my friend borrow the car for a bit (lesson learned, don't), and when it was returned the blower wouldn't blow air anymore, hot nor cold. Fuses are all good. It was blowing air just fine before he got it, and he claims he hadn't messed with it.

Nothing on any push button setting, nor min/max on the wheel. When I hit the defroster, I hear something engage and water gurgling behind the dash, but still no air. Any troubleshooting tips would be greatly appreciated.

Thank you.
 

·
Registered
Joined
·
1,028 Posts
EGv107, learn about the HVAC, pull the blower motor cover off and check.
You will have days of cleaning ahead at the least, and blower motor/rheostat block replacement ahead of you if the motor is siezed.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
EGv107, learn about the HVAC, pull the blower motor cover off and check.
You will have days of cleaning ahead at the least, and blower motor/rheostat block replacement ahead of you if the motor is siezed.
I've been taking a look at the EGv107 but haven't found much specifically related to a non-operating HVAC, nor even how to test the cc. I'll do some more digging tomorrow.

It seems like the control unit probably works, or atleast is doing something since I can hear action behind the dash. Any advise on testing?
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
3 Participants
jreina
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top