Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
OK, new to the forum, just bought a 1986 560 SEL...BIG AND BLACK with red interior...looks like a LIMO!! How much was this back in 1986??? Anyone know...just wondering...

185K miles, it has some issues. I got it for a good price I think...

Heated seats...front driver side doesn't work. How much is this going to run me....

Radio turns on, but gets no reception. I am probably going to replace it with a new one (keep the old though) I have read some other posts on this. Any suggestions??

Car idle feels bouncy, I assume this is standard.

A little blue smoke from the tail pipe...cause??

What kind of oil should I keep in this. I live in Seattle.

any suggestions/tips on this model are appreciated...
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
heated seats, could be a relay, could be the element itself. Could even be the switch. I would swap them out and see where that gets you. Idle is prob. a combination of tired heads, injectors and a possible vacuum leak. This topic has been beat to pieces on this forum:)


Blue smoke is oil..tired valve guides..Quite standard at this mileage esp. if the car lived in the city.

I would run 15-40 rotella in the summer, and some 10 40 come winter.

#1, make SURE that the timing chain/tensioner has been replaced. if not have it done NOW...as in right away now, don't put it off etc..

Also, I would have All the fluids/filters changed/flushed. Brake, p/s (F&F), self leving, trans (F&F), diff, air, coolant (use the MB coolant NO green stuff..).

Also, buy quality filters not pep boys etc crap. Hangst, mann etc..stay away from Bosch filters, they're made in spain.

Jonathan
 
1 - 2 of 2 Posts
Top