Mercedes-Benz Forum banner
1 - 4 of 4 Posts

·
Registered
Mercedes 1986 300E 165,000 miles
Joined
·
110 Posts
Discussion Starter · #1 ·
I have a 1986 300E 137K miles. What is the correct ATF fluid for this? ATF III, Dextron, Mercon??? Also, will it damage the transmission if I have it power flushed?
 

·
W124 Moderator
86 190E 2.3L 16V, 2 95 320TE's, 02 S500
Joined
·
13,181 Posts
Dextron/Mercon III is the fluid. Just drain the transmission and torque converter, put in a new filter and forget about "power flushing". I learn something new every day and have now owned 60 cars. Power Flushing the transmission hasn't ever come across the table.

Good Luck

Jayare
 

·
Registered
Mercedes 1986 300E 165,000 miles
Joined
·
110 Posts
Discussion Starter · #3 ·
Thanks...I did just that and used Dexron/Mercon high mileage....I did a search on numerous forums and they all said use ATF IIE, ATF IID, Dexron/Mercon....it was all confusing. I did a normal flush but did not drain the TC. Now my problem is that the car is not upshifting until very high RPM (6 - 6.5) and I don't think it is shifting to 4th gear. I adjusted the valve (1 full revolution CW) and is still doing it. This started after I stepped on the gas pedal all the way 5 times (car off, ignition off). I read somewhere that this procedure was supposed to reboot the transmission. I checked the cable and vaccum lines and both are fine.
 

·
Registered
Mercedes 1986 300E 165,000 miles
Joined
·
110 Posts
Discussion Starter · #4 ·
I resolved my problem by doing a search on the forum. It was simply the KICKDOWN SWITCH behind the gas pedal. It was stuck down and all I had to do was pull it up and it resolved all my transmission problems!
 
1 - 4 of 4 Posts
Top