Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi, I have 1986 190e 2.3-8 valve, I have converted a/c compressor and dryer, just changed push bottom unit; The compressor comes on, however the hot air from heater blows as well. I changed Klima relay didn't make any difference. Does any one could help me on diagnose the issue, thank you.
 

·
Registered
Joined
·
66 Posts
Hi Henry, does hot air come from the side vents only, and cold air comes from the center vents? On my 1992 2.6 the heater control valve (vacuum operated) located under the passenger side cowl vent (near & below windshield wiper area) was not closing all the way.

There can also be some vacuum issues as well that keep that valve open.

Hope this helps somewhat.
~Bryan
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Hi Bryan, cold air comes from the center front vent and hot air from all other directions, depending to selection. I checked voltage at potentiometer , behind the glove box, I got 0.6 volt for both Min & Max positions! The red vacuum line to heater valve control does not have any suction to close the valve. All other vacuums, doors, vents are OK.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
At engine off and temperature at 65F , Ohm on the potentiometer is 1.3k , temp. sensor for air conditioning (between Klima relay & fire wall) is 14.5k, outside temp. sensor is 3.0k, and in-car temp sensor is 9.4k. They all appear ok within acceptable range.
The switch-over valve is also replaced, it gets vacuum from the source, but no vacuum goes out to heater valve(red), heater valve works with direct connection. Switch-over valve has two identical electrical hook ups, one mostly grey wires and the other is mostly blue colors, does anyone could clarify which one is which and their connections to the switch-over.
I am at odds where the problem may come!
 
1 - 4 of 4 Posts
Top