Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
1984 500SL Euro - When warm engine misses durring acceleration and gets progressively worse

Only after driving for over 1/2 hour engine starts to 'miss' while accelerating, eventually getting where steady speed is only option, even slight acceleration causes engine shaking, engine missing I assume. Changed plugs, dist cap, rotor, coil, disconnected O2 with same results only after 1/2 hour or more of driving, does not seem to be related to engine temperature since engine is well warm well before 1/2 hour or more of driving. Thinking about ignition control box next. Catilitic converter that was installed for import into CA has been removed. I was having problems with rotor tips being burned off, related problem??? Suggestions please
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
Re: 1984 500SL Euro - When warm engine misses durring acceleration and gets progressively worse

David.<br> I recently purchased an 82 500sl that had a very similar problem. It ran very rough under acceleration, but not so bad when you backed off. It ended up being the idle control valve causing it to run very rich. I swaped it over with one from a 380 sl and blocked up one of the vacume lines the wasn't required on the 380 and it ran perfectly.<br> <br> good luck<br> <br> Damian
 

·
Registered
Joined
·
0 Posts
Discussion Starter #3
Re: 1984 500SL Euro - When warm engine misses durring acceleration and gets progressively worse

I had the same problem on my 1981 500 SLC (EURO).<br>
I noticed that after 15 minutes of driving the fuel pump became unusually noisy. I replaced the fuel pump and filter and walah! it cleared up the problem. I assume that upon accelerating, the motor needed more gas but the filter was clogged and causing it to starve. Hope this works for you. Let me know.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #4
Re: 1984 500SL Euro - When warm engine misses durring acceleration and gets progressively worse

David I may have been a bit misleading on my answer to your question the affected part on my <br> 500 sl is refered to as the 'Control pressure regulator' or 'warm up regulator'. I was getting my terms mixed up with another car I have with L Jetronic injection.<br> <br> Regards<br> <br> Damian
 

·
Registered
2001 S430
Joined
·
1 Posts
I HAD THE SAME PROBLEM WITH MY
82 38O SL, MB DEAER WANTED TO
REPLACE FUEL DISTRIBUTER FO...


I HAD THE SAME PROBLEM WITH MY
82 38O SL, MB DEAER WANTED TO
REPLACE FUEL DISTRIBUTER FOR
$1200.00, NO THANKS
I PUT A NEW SET OF BOSH SPARKPLUG
WIRES IN & IT RUNS LIKE AN ELGIN
CLOCK/


TOM
 
1 - 5 of 5 Posts
Top