Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
On my 300d the kickdown switch has always worked fine...until a couple of days ago.

It will kickdown from 2nd to 1st no problem. Withe the key on and pressing the kickdown switch I can hear the solenoid click. So the switch seems to be working ok.

The problem is that I cannot get it to kickdown from 3rd to 2nd anymore or from 4th to 3rd.

As I said it has always worked just fine in the past.

Any ideas?

Has anyone else experienced this?
 

·
Registered
´85 300D Estate, Unimog 411
Joined
·
115 Posts
On my 300d the kickdown switch has always worked fine...until a couple of days ago.

It will kickdown from 2nd to 1st no problem. Withe the key on and pressing the kickdown switch I can hear the solenoid click. So the switch seems to be working ok.

The problem is that I cannot get it to kickdown from 3rd to 2nd anymore or from 4th to 3rd.

As I said it has always worked just fine in the past.

Any ideas?

Has anyone else experienced this?
´
Like some info too...
 

·
Registered
83 300d (broonhilda), 81 240d (clunky), 90 lexus LS400 (lexy)
Joined
·
5 Posts
I am also having a kickdown issue. Mine wont kickdown at all unless im going over 45mph. are you supposed to hear a click when you hold the switch down and turn the car to on?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
Well it seems to work just fine at lower speeds/gears.
I live in the mountains and rely on it quite a bit. I'm very used to how it normally works.

As I said the solenoid clicks when i have the key on and hit the button. It just doesnt work when I'm going I'd say 45 mph and over anymore. It used to be that if i were doing 45 or so that I could kick down and get up to 55-60. Now it does not work at that speed.

Is there an adjustment I can make?
 
1 - 6 of 6 Posts
Top