Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
I own a 1981 380SL. I can get air to come out of the side vents but no longer out of the center vents. The service technician is at a loss on how to fix this. Any ideas? Thanks
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
Paul,<br>
<br>
This happened to my 81 380SL too, but I found the problem, the connection between the vacuum element and the flap for the center jets broke. I fixed it and it works great. You have to look if there is vacuum avalable to the vacuum element before doing anything else. Take the glovebox out and look for the white vacuum hose which goes to the center jets vacuum element. Start the emgine and set the climate control buttons to Auto High. If vacuum avalable in the white hose, that means your center jets actuator doesn't work. If vacuum is not available, that means something else or your servo. If vacuum available, use a 10mm allen wrench to take the steering wheel out and pull the cluster instrument out of it housing, be careful with the wires to the instrument. At this point, you will see the double acting vacuum element, it is close to the center jets. Visual inspect the connection between the vacuum actuator and the flap, if it broke, you can easily fix it. If the connection is good, inspect the vacuum actuator. Turn the climate control bottons to OFF then turn back to Auto High to see how the vacuum element works. If it doesn't work while there is vacuum, that means your double acting vacuum element leaks, you have to replace it. Hopfully this information will help you!<br>
<br>
David
 
1 - 2 of 2 Posts
Top