Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
80’ 450 SL
Joined
·
20 Posts
Discussion Starter #1 (Edited)
All Vacuum Lines are connected. I understand from previous threads I could have a faulty Warm Up Regulator, or Idle Mixture Valve or Idle Air Control Valve (the blue electrical connector on top). Can I service/clean any of these parts as replacements are costly? Can these parts be tested before replaced? I will be replacing the exhaust and the O2 Sensor, but I don't think the problem lies there.
 

·
R/C107 Moderator
1986 560SL: '84 500SL: '84 280SL 5 speed: other 107s
Joined
·
32,135 Posts
Your Idle Control valve is not electrical. It is an AAV (Auxiliary Air Valve) that operates mechanically. It could be the high idle problem. Do a search for AAV or look in the EGv107 section on CIS.

The blue electrical connector is the cold start valve.
 

·
Registered
80’ 450 SL
Joined
·
20 Posts
Discussion Starter #3
Your Idle Control valve is not electrical. It is an AAV (Auxiliary Air Valve) that operates mechanically. It could be the high idle problem. Do a search for AAV or look in the EGv107 section on CIS.

The blue electrical connector is the cold start valve.
I realized I got it wrong after the post. Still learning what is what on this car. Your post is very helpful, thanks. Good to know it could be the AAV. Thanks much!
 

·
Registered
80’ 450 SL
Joined
·
20 Posts
Discussion Starter #4
I realized I got it wrong after the post. Still learning what is what on this car. Your post is very helpful, thanks. Good to know it could be the AAV. Thanks much!
I tried all the suggestions for freeing it up, but the AAV does not move and will be replaced. Thanks
 

·
Registered
80’ 450 SL
Joined
·
20 Posts
Discussion Starter #5
I tried all the suggestions for freeing it up, but the AAV does not move and will be replaced. Thanks
Your Idle Control valve is not electrical. It is an AAV (Auxiliary Air Valve) that operates mechanically. It could be the high idle problem. Do a search for AAV or look in the EGv107 section on CIS.

The blue electrical connector is the cold start valve.
Replaced the AAV today. Car comes down from high idle to 600 to 700 after warm up. Thanks Rowdie. At hot idle it still runs a little rough like my c7. Not terrible but I know the 450sl should idle smoothly. I’ll refer back to the threads on rough idle. Again, thank you!
joe
 
1 - 5 of 5 Posts
Top