Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
OK, I just took the AAV apart, cleaned it and put it back on. Adjusted idle screw to get the idle to 800 rpm. Ran smoother than ever! Took quick 5 mile run and literally as I was patting my own back on this repair the car just died. Cranks fine, gauges come up. Fuses look good. Gotta run back down and see if I can get her to fire up now that's she's cooled off. Not really hearing fuel pump. Could be the culprit. Will advise.
 

·
Registered
Joined
·
330 Posts
If it's not one thing.... this summer as I was commenting to my wife how great the a/c worked, there was a hideous screech and the compressor seized. Gotta be humble.
 

·
Premium Member
Joined
·
9,894 Posts
Could be any one of many things. Maybe just a vapor lock?

I once had a similar experience after setting up timing. But because car was running so well I drove about 10 miles from home on 401 (major highway) to give it a good run. Then car started misfiring a bit. Fuel was low, so I pulled into a gas station but not at pumps. Opened hood and couldn't see anything wrong. Fuel was still about 1/8 full. Decided to fill tank, but could not start car to get to pumps. Had to buy a jerry can and put in a couple of gallons. Still no go. Kind of getting desperate and thought I should call wife to come pick me up and arrange a tow. But she was not at home!

Finally had another look at engine. I found that that green wire (that goes from distributor to connectors near ballast resistors) had touched the exhaust manifold, melted insulation and shorted out. Moved it to safe place and car started and ran perfectly!

Hope you got car running again!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
update

Sorry for delay on update.. was out of town for last week. So I get a ride back to the car, crank and crank, nothing.. Dump a little fuel in open intake and it fires and runs like nothing ever happened. I drove it this weekend and it ran fine.. Maybe a vapor lock as I was "giving it the beans" just prior to it having its little moment. Good news is it is running better with less than 1/2 tank of fuel. Down to about 1/4 and it still performs as it should.. I will refuel tonite and "give her the beans" again and see if I can replicate.
 
1 - 6 of 6 Posts
Top