Mercedes-Benz Forum banner

190E 2.3-16 Clutch Problems

3394 Views 3 Replies 2 Participants Last post by  heckflosse
Hi, i have a big problem and would be grateful if anyone could help.

Basically i was driving my 2.3-16 just after i bought it and on 3 occassion when i went to change gear the clutch had not resistance. I pressed the pedal and the clutch just went to the floor and remained there until i pulled it up with my foot. But then after pumping the clutch i was able to get the car in gear.
On the 3rd occassion after getting the car in gear the clutch began slipping. I thought that the plate had got hot and hence might be causing the slipping, but it still does it even if the car is cold.

Also i thought the slave cylinder may of gone, but i am not sure.

Has anyone had any similar experiences?

Also i am gonna need a new clutch?

Thanks in advance.

Triple-R
1 - 4 of 4 Posts

· Registered
190E 2.3-16
Joined
·
5 Posts
Discussion Starter · #3 ·
Hi thanks for the reply.

If the brake and clutch use the same master cylinder then, i...


Hi thanks for the reply.

If the brake and clutch use the same master cylinder then, i have lost no fluid.

But if the oil level for the clutch is elsewhere, please could you inform me.

I am totally new to this car.

Thanks again
 

· Always Remembered RIP
Joined
·
496 Posts
The clutch master cylinder is attached to the pedal but takes its fluid from the same re...

The clutch master cylinder is attached to the pedal but takes its fluid from the same reservoir as the brake cylinder. I think it's connected by a circlip, maybe this has come away?
It could also be air in the system and might just nead bleeding, else worse case senario either a broken release bearing or a fault with the pressure plate.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top