Mercedes-Benz Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
IM HERE IN THE UNITED STATES AND IM DRIVING AN 87 190D 2.5 TURBO. IT HAS AN ACCELERATION PROBLEM. BETWEEN 1000 RPM AND 3000 RPM ACCELERATION IS VERY POOR, IT IS HARD TO TAKE OFF BUT AFTER 3000 RPM CAR ACCELERATES VERY GOOD. I COULDNT FIND THE PROBLEM, I CHANGED OIL, OIL FILTER AND AIR FILTER. PLEASE SOMEBODY HELP ME AS SOON AS POSSIBLE.
 

· BenzWorld W126 & W201 Host
1988 420SE, 2002 C180 Kompressor, 200 ML320
Joined
·
1,150 Posts
Poor acceleration

sam the man

Why all the SHOUTING?

Is it a turbo?

Has the problem always been there since you owned the car?

How many miles has the car done?

I would recommend replacing the fuel filters if they haven't been changed for more than 36k.

If the fault has been there the hole time that you have had the car, get the pump timing checked.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
POOR ACCELERATION

Spanners,
MY CAR IS 1987 190D 2.5 TURBO. IT HAS 214.000 MILES ON IT. I BOUGHT THIS CAR WITH THIS PROBLEM 2 MONTHS AGO. I ALREADY CHANGED FUEL FILTERS, OIL AND OIL FILTER AND AIR FILTER. I THINK TURBO HELPS FOR GOOD ACCELERATION AFTER 3000RPM. I DIDNT CHECK THE PUMP TIMING YET. WHAT ELSE CAN BE CHECKED BESIDES PUMP TIMING?
 

· BenzWorld W126 & W201 Host
1988 420SE, 2002 C180 Kompressor, 200 ML320
Joined
·
1,150 Posts
Poor acceleration

sam

I didn't realise yours was a turbo, believe it or not there were no 190 series turbo deisels produced for the UK market. However, now I know it is, I would be more inclined to believe the problem is turbo related.

One other idea would be to check the throttle linkage, and make sure when you press the acclerator to the floor, you are getting full throttle.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top