Mercedes-Benz Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Help please!

I have recently purchased a 1993 Mercedes 190D (2.5 Non Turbo) Saloon (Sedan) in ther United Kingdom. It has 131,000 miles on the clock. It has an automatic gearbox. I am happy with the vehicle, but have a couple of concerns.

Firstly, the automatic gearbox is not performing correctly, especially when the engine is cold. When changing from 2nd to 3rd gear, the gearbox pauses the gear change and the revs rise dramtically. This only happens when the car is accelerating 'normally' and can be overcome when the vehicle is rapidly accelerated.

Secondly, I have noticed a vibration when travelling at 60mph or more. The vibration is not felt through the steering wheel, but through the car itself. However, it disappears when I take my foot of the accelerator and 'coast'.

Any help and advice would be much appreciated.

Mark

E320 and 190D
 

· BenzWorld W126 & W201 Host
1988 420SE, 2002 C180 Kompressor, 200 ML320
Joined
·
1,150 Posts
Gearbox + vibration

Mark

I would have the gearbox pressures checked, but before that, make sure the oil level in the gearbox is O.K. and the oil is not black or smells burnt.

The vibration sounds to me to be a problem with the propshaft. The front propshaft coupling where it joins the gearbox has probably perished, which is very common.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top