Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi all,, Hope somebody can help I have a 1989 190 E 2.6,, on start-up when cold just stalls straight away and keeps on stalling,, When I eventually managed to get it started and driving It’s tautly fine and it’s fine run the engine is warm.
Anybody have any ideas?? I am new on here so hope this is in the right forum?
 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
2,230 Posts
Jonty 190,

Any CEL?
Please scan and post any codes.

That being said, it could be a few things:

A starting issue when cold.
Any starting issues when hot?

  • cps on verge of going bad,
  • fuel filter,
  • ignition coils, spark plugs.
 

·
Registered
1989 W124 260E
Joined
·
1,395 Posts
Sounds like cold start injector . Pull the plug off the top see if it is the same with out it . If it is pick up another cold start injector or check to see if voltage is there innthe plug .It will only show voltage for a few seconds . Are all your fuses good in the fise box?.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Sounds like cold start injector . Pull the plug off the top see if it is the same with out it . If it is pick up another cold start injector or check to see if voltage is there innthe plug .It will only show voltage for a few seconds . Are all your fuses good in the fise box?.
Do u mean pull a spark plug off?? Sorry I’m not very mechanical minded
 

·
W201 Moderator
89 190E2.6- 5-speed Manual, 95 E320 Sportsline-sold, 2001 E320 4matic Wagon-sold
Joined
·
2,645 Posts
With all due respect, I'm sorry to have to disagree with the previous posters.
If your car start easily when cold but stalls afterwards you can be assured it is NOT the following 2 items:
(1) Ignition at start
(2) Cold start valve.

I do agree with getting more info on the warm/hot starts. If you can get the car warmed up, can you restart it?
Can you keep the car running when the engine warms up?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Jonty 190,

Any CEL?
Please scan and post any codes.

That being said, it could be a few things:

A starting issue when cold.
Any starting issues when hot?

  • cps on verge of going bad,
  • fuel filter,
  • ignition coils, spark plugs.
No she runs fine as soon as it warms up,,Sorry I’m not very mechanically minded,, I don’t know what a CPS is.. lol
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
With all due respect, I'm sorry to have to disagree with the previous posters.
If your car start easily when cold but stalls afterwards you can be assured it is NOT the following 2 items:
(1) Ignition at start
(2) Cold start valve.

I do agree with getting more info on the warm/hot starts. If you can get the car warmed up, can you restart it?
Can you keep the car running when the engine warms up?
[/QU
Once the car is started and is hot I have no problems with it...
 

·
W201 Moderator
89 190E2.6- 5-speed Manual, 95 E320 Sportsline-sold, 2001 E320 4matic Wagon-sold
Joined
·
2,645 Posts
So how do you keep it running when cold. Do you have to keep pressing the gas pedal and keep the rpm's high?
Does this feel like it is a cold idle problem?

When cold does it starts fairly quickly but then stall afterwards within a second or so?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
So how do you keep it running when cold. Do you have to keep pressing the gas pedal and keep the rpm's high?
Does this feel like it is a cold idle problem?

When cold does it starts fairly quickly but then stall afterwards within a second or so?
Hi thanks for spending the time to reply,, it’s automatic so when I start it I keep the revs quite high, Keep the handbrake on put it into drive release handbrake and it’s fine from thereon,,
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
Hi thanks for spending the time to reply,, it’s automatic so when I start it I keep the revs quite high, Keep the handbrake on put it into drive release handbrake and it’s fine from thereon,,
Also when I first started it,,,it starts straight away but immediately Stalls
 

·
W201 Moderator
89 190E2.6- 5-speed Manual, 95 E320 Sportsline-sold, 2001 E320 4matic Wagon-sold
Joined
·
2,645 Posts
Given the symptoms, I would first see if the IDLE control is working properly (hot and cold)

(1) Disconnect the IACV electrically (after removing the air filter housing) and see how it idles when cold.

(2) Please also report on what happens after you get the engine to warm state with it plugged in and then unplug the IACV electrical connection.

Report on your findings and it is best to itemize your answers so the post is easier to read.

- Cheers!
 
1 - 12 of 12 Posts
Top