Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
Good day every one,

I am really in need of help in fixing my sls pump.

I bought this car with already faulty pump wich was leaking. But i never bothered to fix it before. Couple months ago I tried to get that working, changed the shaft seal, gasket, and rubber o-ring. But its still leaking. I took it off and put it back on, like 8 times, tried to figure out where its coming from. Is there some other seal inside that needs to be addressed? i Don't know. Was looking online for rebuild manual but no luck with google. Am sure its not the engine oil leaking from the valve cover.. Its 100% pump, the oil comes from between those two halves. At this moment i have removed the plate with two notches and flat hole that connects the pump to the cam, so the wouldn't run on dry. Apparently the rear end sags when people on the back seat, since there is no oil pressure comming to the shocks..

Please if any one have any idea on how to fix that, or have any information where i can get the manual, please let me know..

Thanks in advance.
 

·
Registered
Joined
·
2,458 Posts
Have you tried looking in the online manual in the FAQ?

Also, take a look at the EPC to see if you can figure out what you need.

Most people with SLS just converted it to regular shocks for simplicities sake, but it is good you are leaving it stock!
 

·
Registered
Joined
·
131 Posts
good kit and thats what I used to rebuild mine. I think it now comes with how to instructions which it didnt use to have.
Tip:
torque the bolts evenly and do not overtighten or youre gonna end up warping the aluminum body and cause a leak.
I think the torque value is 20 ncm but I am not exactly sure. Its in the manual.
 
1 - 4 of 4 Posts
Top