Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, replaced blend door motor. new motor doesn't move
all linkage and doors move freely.
Checked supply voltage(t15 and t30) at control unit mounted behind climate control knobs
found 12.1v at pin#9, checked pin#7 for ground signal.
incar temp sensor plugged in.
I see from other post that motor goes to full heat position if temp sensor is unplugged
Tried that, still no movement.
Recirc.door motor, blower fan,a/c comp all working properly.heater core hot.
Can anyone help with pin testing a/c E.C.U. for diag of system?
Motor is new part from local MB dealer
99 ml 320
Thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The blend door motor (m16/8) is in the center of the linkage travel.
It came out of the new part box in this position
Yes, I had the pin #s switched,circuit 15 and 31.
Do you have a wiring diag for N19 and m16/8 ?
I believe there can be only 3 possible problems; N19, m16/8 or wiring harness issues
N19 is properly controlling fan speed and recirc door.I suppose it can be partially defective. m16/8 is new O.E.M.and I think that the system defaults to full heat if the
in car temp sensor or temp select switch is defective.
Thanks
 

·
Registered
Dallas, Texas
Joined
·
7,735 Posts
The blend door motor (m16/8) is in the center of the linkage travel.
It came out of the new part box in this position
Yes, I had the pin #s switched,circuit 15 and 31.
Do you have a wiring diag for N19 and m16/8 ?
I believe there can be only 3 possible problems; N19, m16/8 or wiring harness issues
N19 is properly controlling fan speed and recirc door.I suppose it can be partially defective. m16/8 is new O.E.M.and I think that the system defaults to full heat if the
in car temp sensor or temp select switch is defective.
Thanks
N19 does not control fan or recirculating motor. Those are controlled through S98. What was original problem that prompted you to replace blend flap motor?

.
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Blend door motor was clicking , after about 3 weeks clicking stopped and stuck in cold position.I went thru previous post and found several issues and how to articles about blend door clicking and replacing.
I read at this site that n19 controlled fan speed etc.after request from S98
Car Air Conditioning: Mercedes M-Class Model 163 climate control system '98 to '01
Without a wiring diag, I am unable confirm any addt. defective part.
Thanks again for any info
 
1 - 5 of 5 Posts
Top