Mercedes-Benz Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I just recently picked up an 07 Mercedes GL450 (high mileage) and I was heading out of town on the highway doing about 120 cars an hour when the SRS malfunction popped up and the vehicle died on me stuttering until I came to a complete stop. Besides all the fuses and relays been working on it for the last 4 days trying to figure it out as I am a technician myself I just have not dabbled with Mercedes too much. The front Sam module was badly corroded but I cleaned it up and it doesn't throw code to the front module anymore just the rear. The ignition switch is also throwing up on fault code such as voltage. The battery is newer along with the secondary battery. I'm 95% sure I checked all the cheeses and relays. Seems that further I dig into it the more it could be. Any suggestions would be amazing
 

· Registered
GL350 BlueTec
Joined
·
186 Posts
I just recently picked up an 07 Mercedes GL450 (high mileage) and I was heading out of town on the highway doing about 120 cars an hour when the SRS malfunction popped up and the vehicle died on me stuttering until I came to a complete stop. Besides all the fuses and relays been working on it for the last 4 days trying to figure it out as I am a technician myself I just have not dabbled with Mercedes too much. The front Sam module was badly corroded but I cleaned it up and it doesn't throw code to the front module anymore just the rear. The ignition switch is also throwing up on fault code such as voltage. The battery is newer along with the secondary battery. I'm 95% sure I checked all the cheeses and relays. Seems that further I dig into it the more it could be. Any suggestions would be amazing
Hello. Let's start with what codes is the car displaying, meaning check engine codes. GL.
 

· Super Moderator
1986/1990 W126
Joined
·
21,214 Posts
I just recently picked up an 07 Mercedes GL450 (high mileage) and I was heading out of town on the highway doing about 120 cars an hour when the SRS malfunction popped up and the vehicle died on me stuttering until I came to a complete stop. Besides all the fuses and relays been working on it for the last 4 days trying to figure it out as I am a technician myself I just have not dabbled with Mercedes too much. The front Sam module was badly corroded but I cleaned it up and it doesn't throw code to the front module anymore just the rear. The ignition switch is also throwing up on fault code such as voltage. The battery is newer along with the secondary battery. I'm 95% sure I checked all the cheeses and relays. Seems that further I dig into it the more it could be. Any suggestions would be amazing
This is good to do if you don't mind please. Vehicle details in the profile.

 
1 - 3 of 3 Posts
Top