Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have a 04' S55 with 157k miles and recently had a guy replace my spark plugs with champion iridium plugs ''9006'' i bought online. after I picked the car up i noticed it had a rough idle at times and idles a little higher than usual and a star tool screw was missing out of one of the 8 coil pack boxes.Also check engine light comes and goes.After scanning with OBD reader it came back with codes P0507,P0505 twice,and P0455 all relating to air system leak or idle air control system.Any help is much appreciated, thank you!!!
 

·
Registered
2000 S430, 2003 S430, 2000 S500, 2003 S600 TT, and 2005 E320 CDI
Joined
·
4,558 Posts
This is why I do all my own maintenance now. That "guy" screwed something up. My guess is that one or more of those spark plugs wasn't torqued down properly...or the coil pack wasn't plugged in fully.

Seriously, that kind of stuff is easy stuff that you can learn how to do. Ask the other people on this forum; I haven't been doing it very long at all, and there's a bunch of stuff that I now do. You can, too.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
This is why I do all my own maintenance now. That "guy" screwed something up. My guess is that one or more of those spark plugs wasn't torqued down properly...or the coil pack wasn't plugged in fully.

Seriously, that kind of stuff is easy stuff that you can learn how to do. Ask the other people on this forum; I haven't been doing it very long at all, and there's a bunch of stuff that I now do. You can, too.
Thank you,im new to this forum still trying to figure out everything
 

·
Registered
Too many to list
Joined
·
8,736 Posts
Did you have any problems before having the work done ? Why did you have the work done originally , were you having problems
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
Did you have any problems before having the work done ? Why did you have the work done originally , were you having problems
I bought the car at 122k and didnt know forsure how long since they were last changed i just figured i should change them since ive put about 35k on it while ive had the car.
And no,i havent noticed any issues like this before changing the plugs.
 

·
Registered
2004 S55 , 2005 S55 , 2004 S430
Joined
·
89 Posts
I know the plug wires are a pain to remove from the plugs, a 17mm wrench helps but still have to be able to get wrench in position and room for leverage but they can be difficult to reattach correctly if assembly silicone lube/ dielectric grease isn't used. You should feel or hear a click when seated. I fixed a s430 recently where some amateur put new wires and coil packs on and none of the wires were all the way seated, all kinds of misfiring.
 
1 - 7 of 7 Posts
Top