Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
277 Posts
Discussion Starter #1
Hi folks..

I have had no problem with the 03 ML350 since I purchased it untill Wednesday which happens to be also my birthday. I was at a ski resort and about to go home have a dinner for the celebration; the ML just turned me down. We were about to go home and once I tried to start the engine, theres no response at all. Battery shows fine, headlamp is working, and theres not even "tick" sound at all. So eventually I needed to call the roadside assistance and get my truck towed to the dealer. The dealer is still working on it and checking if my ext-warantee covers it. I'm wondering if any of you have had same experience before? Thanks
 

·
Registered
Joined
·
1,662 Posts
My 2005 ML 500 had a similar problem.

I am sure there are many potential reasons that will cause a similar behaviour, but in my case it ended up being a loose starter connection.

In my case, when I tried to start, there was no click and no noise whatsoever. The most important hint was that the lights on the dashboard will not dim at all. Meaning that there was no power being delvered to any place.

The dealer, at first, could not find the problem since later it will start fine for some time. Finally the dealer did a very good detective work and found that the starter wire was loose. Since then I never had that problem again.

AC
 

·
Registered
Joined
·
519 Posts
Exactly my symptoms, and could explain the eltrical shorting sounds I heard..

My 2005 ML 500 had a similar problem.

I am sure there are many potential reasons that will cause a similar behaviour, but in my case it ended up being a loose starter connection.

In my case, when I tried to start, there was no click and no noise whatsoever. The most important hint was that the lights on the dashboard will not dim at all. Meaning that there was no power being delvered to any place.

The dealer, at first, could not find the problem since later it will start fine for some time. Finally the dealer did a very good detective work and found that the starter wire was loose. Since then I never had that problem again.

AC
 

·
Registered
Joined
·
277 Posts
Discussion Starter #4
thx for replying

The dealer finally got time to check my truck and told me that a wire was loose and that why it didnt' start. The dealer told me that it is no covered under warantee and I'm curious how the price that they ganan charge me. They also found a faulty ESP something and its under the warantee. Sigh
 

·
Premium Member
Joined
·
16,769 Posts
thx for replying

The dealer finally got time to check my truck and told me that a wire was loose and that why it didnt' start. The dealer told me that it is no covered under warantee and I'm curious how the price that they ganan charge me. They also found a faulty ESP something and its under the warantee. Sigh
This is what's called "double banging". For the same exact problem, the dealer will bill the the warranty company for the ESP problem and then bill you for the loose wire problem. But make no mistakes about it, THERE WAS ONLY ONE PROBLEM AND THEY ARE GETTING PAID TWICE.
 
1 - 5 of 5 Posts
Top