Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
2002 E320 4MATIC
Joined
·
7 Posts
Discussion Starter #1
2002 E320 4MATIC, 174k miles

My wife drove the car to work today and had some issues. She said the doors wouldn't lock with the key fob. She could lock them from the inside. She locked the driver's side door with the key and unlocked them with the fob. Then she was able to lock the doors with the fob.

In the afternoon, she drove the car a couple of minutes and it stalled on her. No CEL, no warnings on the dash. She was able to restart the car. She was able to drive home with out any issues.

After about 30 minutes of her parking the car, I went out to start it and the starter ran (15 secs maybe). I turned the car off and tried to start again and the engine again took at least 5 seconds of cranking to start. CEL came on.

Drove it to PepBoys to get the code read. There were four codes--

0305-Cylinder 5 misfire
0335-Crankshaft Position Sensor A Malfunction
0134-02 Sensor B1S1 No Activity Detected
0154-02 Sensor B2S1 No Activity Detected

Awesome. Also noticed that the water temperature was a little high (about 90*C) though it has been hot today.

The car seems to run fine while driving it. There hasn't been any warning of problems coming. Is it possible that all these things happened at once? What is wrong with the car?
 

·
Registered
2001 E320 RWD- 2011 E350 4M
Joined
·
575 Posts
Your problem is CPS, pretty common with W210s check out the stickys, there are really good ones about how to change it, it's not an expensive fix but to find the location of the sensor and getting the damn thing changed is a pain in the arse.
90 degree temp should be ok, I would not worry about it now.
Good luck
 
1 - 2 of 2 Posts
Top