Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
W639
Joined
·
327 Posts
Discussion Starter #1 (Edited)
Engine management light came on this morning, severe restriction in power and limp mode preventing revving above 3000rpm. Even below 3000, the van hardly pulls and only just got up to 40mph.

I called the dealer - £80 for an hours diagnostics! They said "Is that OK sir?" and I said "No!" so currently investigating other options.

56 plate 111CDi with 40k on the clock
Engine light showing - sever power restriction

I limped home, turned it off and let it sit for a hour. Turning the key again, the engine comes on with no light, runs for a few seconds then the light comes on and the engine note changes audibly, sounds lower and gruntier somehow.

Manual says injector or exhaust problem - had a poke around but nothing obvious from just popping the bonnet.

I haven't got much time and not been under the bonnet of this one at all (knew my old 110 pretty well) so after a search, wondering if there are any pointers before I give in and just cough up £80 at the dealers!
 

·
Registered
Vito 115 4x4
Joined
·
115 Posts
HmmM.
Sounds expensive.

My friendly mechanic did it for nothing. (See http://www.benzworld.org/forums/v-class/1389434-ok-so-you-have-heard-before.html#post4433101 )
Sure he will charge me for fixing it, but diagnosis was free.

Look around for an independed garage that works the firm.
In the 30.000 people town that I live, there are three.
There must be someone near you.

Failing that, pay the dealership. The lap top thing will save you trouble and money in the long run.
 
1 - 2 of 2 Posts
Top