Mercedes-Benz Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 22 Results
  1. W163 M-Class
    I bought this truck from a man who let it sit in his yard for about a year. He bought a new car and never thought about selling it until I approached him. Anyways It had to be boosted off and it had a slight miss. Driving it home the engine light came on and it ended up I had to replace a coil...
  2. W210 E-Class
    Hello all! I have a 1997 e420 with 157,000 miles. A few months back I had my first misfire and it ended up being the cylinder 2 coil. I’m going to switch coil 5 and 6 to see if the misfires follows to 6. I had a question about ignition coil brands, I went with Mercedes but now I want to just...
  3. W210 E-Class
    So recently within the last two weeks the engine is making a weird type of sound and when it makes this sound I feel a slight vibration throughout the car. Only happens when I'm idling in reverse or drive with the a/c on. Almost like a click type of sound or electricity arching type of sound...
  4. W140 S-Class
    Hi Everyone, I need to start by saying how much I appreciate all of this group's efforts over the years to document so much about these cars. --- I'm no beginner when it comes to the w140 but I've been stumped by a misfire at idle: Car: - 1995 S420 Long wheelbase. California Car (Distributor...
  5. W203 C-Class
    My 2002 C320 originally had a misfire on cylinder 1. The car would run fine, then once a load was put on the engine, it would detect a misfire and shut off cylinder 1. It would also happen after it worms up and the ideal becomes rough. To try and fix it, I replaced the spark plugs and fuel...
  6. W124 E,CE,D,TD Class
    Hi everyone, With the motivation and push from a few members (specifically H.D. ;)), I have decided to create a new thread to consolidate all testing procedures surrounding the M103 engine. Please understand that there may be minor variations between the engines (2 pin vs 4 pin/EGR/Non-EGR)...
  7. W124 E,CE,D,TD Class
    Hi, I have been trying to figure out my 230E´s (1992 200k miles M102.985 engine) running problem for pretty much 15 months now. It started with some occasional vicious misfires that seemed like the whole engine cut off for a tiny moment before running normally again. I changed all plugs, whole...
  8. W211 E55 AMG, E63 AMG
    Got my fuel sending unit on my 55 replaced on thursday (at the MB dealership). On sunday the car suddenly misfired like crazy during downshift+acceleration. A few min later it just stalled. Hard to start after and it stalled once more. Didn’t try to start it 3rd time. No codes when I plugged...
  9. R/C107 SL/SLC Class
    Hey everyone, Hoping to get some help diagnosing a new issue I'm running into with my 1984 380sl (170k miles) Recently had my passenger side camshaft, rocker arms, valve cover gaskets and washers, and cam oiler kit replaced about ten days ago. Two months ago I had engine mounts, front...
  10. W163 M-Class
    Hi all, So I recently got these codes on my ML: P0306 - Cylinder 6 misfire P0130 - 02 Sensor Circuit Bank 1 Sensor 1 Because I had not replaced the plugs and wires since 2004, I went and did all 12 plugs and wires. I also moved the cylinder 6 coil pack to cylinder 5 to see if that may move the...
  11. W204 C-Class
    Hi all, I own a 2009 cls63 and a few months back I had a minor misfire in the engine so I cleaned the fuel injectors and spark plugs and it worked fine for a few weeks then again misfiring occurred but this time it gradually became worse and started misfiring and vibrating when idle and worked...
  12. W203 C-Class
    This happened after the cold flash that happened in Texas which me or my car is not used to, my car is an 07 c230, the car sat in the cold (I had no need to go anywhere) for around 3 days which seemed normal but when I went out to start it, it didn't want to turn on(cranked but not coming on) ...
  13. C209/A209 CLK-Class
    I have a 2007 CLK350. So I asked a question about this a couple weeks ago on this forum, but now I have some more updates. The check engine light recently started turning on with fault codes P0015 and P0025. I took it to the shop and they weren’t sure if it was a timing issue or a solenoid...
  14. W124 E,CE,D,TD Class
    Hey everyone! I think I have reached my wits end with this issue and now I am hoping someone here can steer me in the right direction. I just finished the manual swap using the 717.404 getrag manual transmission and parts from a w201. The car was running well before, but now is consistently...
  15. R/C107 SL/SLC Class
    Hi all, Started to drive my 76 450SL often these days. I'm puzzled by how the M117 engine is misfiring. There are no problems when the engine is cold and semi warm, it idles very smooth. However a while after it gets to operating temperature it misfires randomly at rpms lower than 3000...
  16. R/C107 SL/SLC Class
    Dear friends of the Benz, My first thread - I'm nervous but excited to learn more about my problem. I've been using the wealth of knowledge on this site for years now - what an excellent resource!! So my issue: I have been having significant problems with misfiring and stalling during the...
  17. W203 C-Class
    Hi, I have a 2006 C230 Sport it has a flashing check engine light when I start up the car but stays steady after about a minute or so. It smells like rotten eggs sometimes but I can smell the raw gas. The car also shakes when idling but goes away when revving it up and before this issue happened...
  18. C209/A209 CLK-Class
    Just got a 2006 clk350 coupe 139k. Previous owner did little to no maintenance. He did install new intake (thank you) but it had several misfires rough idle and surging (800-1100 rpm) code reader was only showing misfire codes (1,3,4,5,6) So i started from scratch. -new battery (old one was from...
  19. W211 E55 AMG, E63 AMG
    Hello everyone I pretty much hit bottom here trying to figure out what’s wrong with my car..it started with a cel out of nowhere (p0018) then the car misfires like crazy (cylinders 6,7,8) but if I turn the ignition off and turn the car back on it runs good for like 20+ minutes ...so I changed...
  20. W204 C-Class
    I have a 2013 c250 160k miles with the M271.8 engine. Hopefully someone here will have an idea! I recently changed my high pressure fuel pump, HPFP, the day after replacing the pump my car would idle really rough and misfire for 45 seconds then itll rev up 1500-2000 rpm and drop back down to...
1-20 of 22 Results
Top