Mercedes-Benz Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 22 Results
  1. U.S. - South
    I am looking for an audio shop to install a stereo system I order to gain current technology. Bluetooth, CarPlay, rear camera desired with the ability to integrate the steering wheel control buttons. 2004 SL 500 with Comand and Bose Audio system. R230 in Houston TX
  2. Audio & Telematics Forum
    So I had relegated myself to the fact that the car and the phone could connect to Bluetooth but only for phone calls. Any audio would need to go through the 3.5 mm auxiliary Jack. That's fine I can plug in but I came out of an appointment the other day, got in the car and heard my phone's...
  3. W213 E-Class
    So a month ago my car wouldn't start, I took the car to the mechanic and he said that the computer was dead and they had to put a new computer and reprogram it. (took them 2 months) Finally, they started the car and also changed the battery. Now the car starts just fine but I have many major...
  4. W221 S-Class
    So I was checking out how to retrofit an AUX input to my merc since I don't have one in my glovebox, so I had some questions for you guys since i am an amature when it comes to mercs. I found this video but i was wondering if i need to just buy a 3 cabled female AUX cable or do I need a...
  5. W211 E-Class
    Hello guys! I am looking for some guidance on how to solve an audio related issue. Whenever I turn the volume up for a larger amount it starts to stop for milliseconds. In order to increase the volume I must reduce the bass level. I have tried checking out the AGW fuse (40 amp), then I replaced...
  6. W220 S-Class
    Hell all! I'm currently working on a restoration of my 2004 w220 s430. I am looking for a good Bluetooth compatible head unit - anyone have any suggestions on one that wont break after a week installed? Not looking to go cheap - I want quality! thanks for any help! Jon
  7. Audio & Telematics Forum
    I just bought a ml 320 pretty sure it’s base model but it has a Bose sub under my seat. Well what I’m tryin got do is get my current radio I got off Amazon to work with the car. It fits the plug with the double just fine and plays. But the radio lacks another place to plug the sub in at. I have...
  8. Audio & Telematics Forum
    Hi all, we’ve just received a lovely little 2007 A170 Elegance. We need to replace the speakers and was wondering if anyone knew the size of the front centre speaker? The audio store could find the front and back side sizes, but not the front centre.
  9. Audio & Telematics Forum
    My 2001 R129 tape reader appears to not be working. Its the first time I try it since I got it and it doesn't read. From what I read in the user manual, a light push of the tape should make the radio "catch" the tape and start working. Instead, when I push it lightly, the screen reads SIDE 1 for...
  10. Audio & Telematics Forum
    Hi All, I have an issue with my 2014 W176 while trying to use the Media Interface under the Audio menu. It powers on with ignition for 15 seconds then turns off , all other ports are fine, it’s only an issue with the AMI port in the armrest for Media Interface. Any ideas? thanks, Shawn
  11. W211 E-Class
    I recently acquired a US 2008 E550 4Matic, and I love the car to bits. However, my one qualm with it is the infotainment system is a touch antiquated. As such, I was wondering if it would be possible to replace the head unit with something a bit more modern, while still being able to use the CD...
  12. Audio & Telematics Forum
    my C216 Cl500 has an issue with the audio volume when I get in and start the car. It automatically goes too loud and I am at odds as to how I can reprogram or stop this from happening. Any ideas would be gratefully accepted.
  13. Audio & Telematics Forum
    Hi About 2 days ago my 2009 ML 350 wouldnt start. When I started it it gave me a click sound. So I thought it was the starter. Called the towing company when they came they said looks like you need a jump and that is what he did and it started right away. Drove it to the mechanic and he said to...
  14. C209/A209 CLK-Class
    Hi all, I'm having a strange problem with my stereo and hoping to get some help. I can’t stand the adverts on the radio so have always listened to music/podcasts from my phone. It’s plugged into the headphone lead and into the jack in the glovebox. Recently though the quality had dipped...
  15. For Sale/Wanted/Trade/Giveaway
    Up for grabs is an audio output interface (TOSLINK or analog RCA) for a Mercedes (2015+) that uses the MOST150 fiber bus. This device gives you a clean signal to use with aftermarket amps or a DSP in your Mercedes. I used this module in my W205 C43 with Burmester and it worked great!!! This...
  16. Audio & Telematics Forum
    Hi guys, just recently found this forum and thought I'd stop by to ask a few questions about my new 2002 SLK320 that I got with 60k miles on it🥳. So I'm a bit of an audiophile and decided recently to buy the Sony DSX-A415BT, along with the items that Crutchfield says I'll need; Metra 40-VW12...
  17. W211 E-Class
    Hi! Got my 2003 E320 about a moth ago and im in love with the car! The only issue I had was that my car didn't come with the aux input in the glove compartment so I decided to retrofit a newer headunit to get the aux input. I took out my old unit to see what connections I had and placed an...
  18. Audio & Telematics Forum
    Hello, I recently installed an Alpine UTE-73BT headunit and front component speakers in my 2011 GLK350 4Matic originally equipped with base Audio 20 system (no amp, no nav, no camera, no sub). All equipment was purchased from Crutchfield and the install went smoothly, plug and play for the...
  19. W123 E,CE,D,CD,TD,TE Class
    Hello all. Just picked up some front speakers and realised the tweeter in the front speakers are too big. Without cutting into the plastic grill cover, has anyone tried to fit them in from underneath? If so, any help would be appreciated. Also, looking to fit a sub/amp in boot, any guides or...
  20. Audio & Telematics Forum
    Hello, Ive been working with a couple different shops to try to get to the bottom of some issues I have been having with my audio. Originally I had a blown out left door speaker which we replaced with a factory speaker. Once I replaced it I realized the sound originating in all 3 door speakers...
1-20 of 22 Results
Top