Mercedes-Benz Forum banner

Search results

1-20 of 209 Results
Advanced Search
  1. 1995 s320 for sale

    W140 S-Class
    Hey guys, I think its time to get rid of my s320. unfortunately the cost to repair the transmission are too high for me to keep this car. I am selling it as is, everything but the transmission works great. I have a body kit on it with 19inch BBS rims. i will post pictures later this week...
  2. 1995 s320 transmission problems

    W140 S-Class
    thank you very much for the advice guys.
  3. 1995 s320 transmission problems

    W140 S-Class
    Hey guys, I have a 95 s320. its got about 165K miles on it. The transmission cooling lines blew. I took it to the mechanic and he just changed the transmission lines and told me I'm good. I should have known better. Soon after, the transmission lines blew again. took it back to the...
  4. 1999 S320 SWB Door Locks Suddenly Not Going Up and Down

    W140 S-Class
    I just had my pse pump rebuilt. If you need the info it's a place in Florida. I shipped mine out to them. Took about a week and a half. Cost me 125 plus shipping
  5. Parts for you. W140

    W140 S-Class
    do you have pictures of the shift knob? and how much. ty Laz
  6. auxillary fan issues

    W140 S-Class
    wanted to give everyone an update on this. After having someone look at the car, they told me it was the fan clutch. I just had it changed today and the car goes to 106 degrees and then drops down. today wasnt that hot so im waiting for a nice hot day to test it out. if anyone needs a good...
  7. auxillary fan issues

    W140 S-Class
    I am still trying to figure it out. After vacuuming and refilling the ac system, I still have the issue. Actually can't drive my car now because it keeps overheating.....I don't know what else to do other than take it to the dealer and get raped. Sent from AutoGuide.com Free App
  8. auxillary fan issues

    W140 S-Class
    if i jump the wires, then the fans come on full speed. tonight i will vacuum out my AC and refill. but shouldn't it still go to high speed once the temperature reaches 105 degrees? or does it have to meet the pressure in the ac AND the temperature for high speed to kick on?
  9. auxillary fan issues

    W140 S-Class
    i have changed the relays and the resistors. now the fans will come on low speed when i put ac on full. no full speed on the aux fans, unless i jump the temperature sensor on top of the thermostat housig.
  10. auxillary fan issues

    W140 S-Class
    i have checked the power coming to the fans, and nothing. i was told to check that relay behind the headlight but i cannot find it just by looking and will have to wait for the weekend so i can jack the car up, i was told its under the headlight behind the bumper.
  11. auxillary fan issues

    W140 S-Class
    absolutely. it goes to the red line if i dont either turn on the heat or put the car in neutral and rev it p to spin the main fan faster and then the temperature drops. the aux fans do not turn on at all no matter what.
  12. auxillary fan issues

    W140 S-Class
    I have searched and searched all over this site, other MB forum sites, and also did a google search and have looked at everything to fix my issues. my auxiliary fans do not want to turn on. i have changed the relays, both of them, the thermostat, coolant temperature sensor, the one with 2...
  13. W140 OIL info(sythetic vs regular)

    W140 S-Class
    i have a 95 s320 and i have switched over to synthetic a few years ago..... cars running great....if you make the switch, i heard and did it too, that you have to transition the switch.... can go 100% synthetic right away.... first old change, do 75% regular, 25% synthetic, second, 50/50, and...
  14. DUOVALVE!!!!!!!!!!!

    W140 S-Class
    my friend runs his own shop in west orange....where in jersey are you??
  15. DUOVALVE!!!!!!!!!!!

    W140 S-Class
    its been like 3 weeks now and mine is working great....so, hopefully it will stay like that...
  16. DUOVALVE!!!!!!!!!!!

    W140 S-Class
    Hey everyone, i just recently found a quick fix for the duovalve........ my ac was working really funky some weeks ago.... blowing cold air on one side and hot air on he other, even though the ac was on in the climate control on both sides....my friend, who is a mechanic, traces down the...
  17. parting out TAN intererior of my 96 s500

    W140 S-Class
    what about the plastic on the driver side that is next to the seat that holds the lumbar control support?? how much would u want for that and how much to ship to NJ???
  18. CAR IS RUNNING AGAIN!!!!!!!!!!!!

    W140 S-Class
    well, everything was fairly easy for me cause i didnt do the work...HAHA.... well, my friend is a mechanic and he did all the work for me..... the spark plugs and wires were fairly quick and painless..... took him about 15 minutes..... if the old wires didnt fall apart when he was changing them...
  19. CAR IS RUNNING AGAIN!!!!!!!!!!!!

    W140 S-Class
    FINALLY GOT MY CAR UP AND RUNNING AGAIN.... TOOK ME SOME TIME, BUT FINALLY TRACKED DOWN THE PROBLEM......AFTER CHANGING THE ENGINE AND HARNESS, IT WAS STILL MISFIRING.... THEN I CHANGED THE PLUGS AND WIRES!!!!!! FINALLY, THE CAR FEELS LIKE NEW AGAIN..... NO MORE CHECK ENGINE LIGHT AFTER THE...
  20. im back!!

    W140 S-Class
    bad luck well, i finally got the car on the road...drove it for most of the day perfectly...then my bad luck struck.... i knew it was too good to be true.... misfire and limp mode again.... but now i have traced it backto the spark plug wires and the plugs themselves because the wires have...
1-20 of 209 Results
Top