Mercedes-Benz Forum banner

Search results

1-13 of 13 Results
Advanced Search
  1. ML500 2002 P2090 code

    W163 M-Class
    I dont think so. Now there is no any code. Also nothing was disassembled in that area for years (maybe never). I meat that on some hard accelerations (not every one) bank2 upstream o2 sensror going rich (so its good), and bank1 o2 upstream sensor going lean (should be rich). . Im thinking about...
  2. where are ML's manufactured

    W163 M-Class
    I dont wanna have fun of US made ML :) I'm just saying what every ML buyer can read on the W163 website, pages etc In my country this is simply accepted as a fact now Offtop: month ago i have sell VW jetta from the us (in europe bora, golf4) and comparing eu vs europe i must admit that vw make...
  3. where are ML's manufactured

    W163 M-Class
    Mine too, i have heard that MB ML's made in America have so bad assemebling quality that they want to improve this by making in Austria some ML . So for this moment in my country people said to buy ML only form Austria mad, and never imported from US :)
  4. ML500 2002 P2090 code

    W163 M-Class
    Update :) After few days of working with ML, i think its gonna work now :) I have cleaned connectors with contact cleaner + comressed air (4 x o2) + change left and right upstream o2 sensor for used but working one. For this time these codes havent back, so i think its ok now. But in fighting...
  5. ML500 2002 P2090 code

    W163 M-Class
    Oh i know, a few years with mercedes taught me that "anything is possible" :) So i put this on my list "to check".
  6. ML500 2002 P2090 code

    W163 M-Class
    Sorry I heard about this , but as i remember it was about downstream O2 sensors not upstream. Or i remember wrong?
  7. ML500 2002 P2090 code

    W163 M-Class
    You mean rain could get in the car? I never see something like this. Why do you ask? Also I remembered that in this year i have done: all engine vaacum hoses sealing intake tube to throttle body cleaning throttle body all filters (air, oil, new oil, new coolant) new valve cover gasket I'm...
  8. ML500 2002 P2090 code

    W163 M-Class
    Hello friends! I need Your help :( My ML killing me again, today the problem is code P2090 (from alldatadiy ) P2090 [8] O2 sensors upstream TWC: : Plug connections of the O2 sensors are wrongly connected. (P1999) I read this with my carsoft v12 tool, and i dont touch O2 sensor for almost...
  9. W163 ML500 2002 REAR SUBFRAME REPLACEMENT

    W163 M-Class
    Hello! Few months are gone, but work is done 🙂 After that I have some trip so i cant post pictures. I have used 10.9 M14x65 (as I remember) bolts with nuts. And screw it together on 200Nm. For now everything seemss to be good. Have a nice day and thanks for helping.
  10. W163 ML500 2002 REAR SUBFRAME REPLACEMENT

    W163 M-Class
    Thank you! My teacher would not be delighted either. :) I just wanted to show the solution and not sell a patent for Mercedes :) Yes, thats very good idea. These bolts go to the trash for sure! But please explain two more things (maybe my English is not so good that I do not understand): 1...
  11. W163 ML500 2002 REAR SUBFRAME REPLACEMENT

    W163 M-Class
    So how should I understand this? If these four screws are disassembled, then the rusted plate will came off?. Just replace it with new plates plus bolts? I would prefer not to weld anything to the frame if I do not have to, and not to cut anything (little space), because it causes problems with...
  12. W163 ML500 2002 REAR SUBFRAME REPLACEMENT

    W163 M-Class
    Thank You Witek for answer! So that's not good... I have bought a completely new rear frame, I thought to use special longer bolts of 10.9 class with nuts. In addition, I wanted to give a plate with a hole (thickness about 8mm). Mounting (on the main frame) looks good, in addition to the...
  13. W163 ML500 2002 REAR SUBFRAME REPLACEMENT

    W163 M-Class
    Hello everyone! I have very rusty rear subframe on my ML500, so i want to change this. Please answer me how it screwed (rear subframe to frame). I saw 4 screws (I think they were M12x50 10,9) but I did not see any nuts (I have a lot of rust on top) The front subframe is screwed in the same...
1-13 of 13 Results
Top