Mercedes-Benz Forum banner

Search results

1-20 of 42 Results
Advanced Search
  1. Water Sloshing, Drains Clogged?

    W164 M-Class
    43sqd helped me with this same problem on a 2008 ml350. U can get the upgraded gaskets on fcpeuro.com U got lucky. I found out the gaskets were bad after the water took out the rear sam Sent from my SM-N960U using Tapatalk
  2. Code clearing procedure

    W221 S-Class
    I would like to know how to clear fault codes with a code scanner. on a 2009 s550. Do u have to have the engine on? Running or not? Thanks for the help Sent from my SM-N960U using Tapatalk
  3. 2008 ml350 Abs ring

    W164 M-Class
    Yes. Cleared the codes several time. But I will check for the ring tonight. Sent from my SM-N960U using Tapatalk
  4. 2008 ml350 Abs ring

    W164 M-Class
    So I had the mechanic next door change out my front wheel bearing because of a grumbling noise. While doing so he discovered the front right cv axle was going bad too. So he put in a new axle in the front right, new bearings and new speed sensors. No more noise but now we have abs lights...
  5. Constant ticking from engine

    General Mercedes-Benz
    My wife had this in her 2008 ml350. It was the upper belt tensioner. Changed it out and now no ticking Sent from my SM-N960U using Tapatalk
  6. Replacing the drivers side front air strut

    W221 S-Class
    https://www.fcpeuro.com/products/mercedes-shock-assembly-front-left-s-class-w220-arnott-as-2304 I dont know what year u have but his is for an 09 w221 Sent from my SM-N960U using Tapatalk
  7. Maintenance service 2009 s class

    W221 S-Class
    Thank you. Sent from my SM-N960U using Tapatalk
  8. Need a part number

    W164 M-Class
    I have a ml350 4matic and I need the part number for passenger and driver side complete steering knuckle. Thanks for the help. Sent from my SM-N960U using Tapatalk
  9. TOPSIDE OIL CHANGE QUESTION

    W164 M-Class
    I use the mityvac for a 2008 ml350 and a 2009 s550. The hoses that come with it does down the dipstick fine with plenty of play. But u will want to go the lowes and get longer hoses so u can put the mityvac on the floor. I even upsized the hose so it would recover the oil faster. Sent from...
  10. Evaporative emissions sys stuck shut

    W221 S-Class
    I checked the wiring going to the plug. It is not getting a ground. From what I have heard whatever controls the valve does it though the ground wire. I actually cut the plug out. Tripped the wires and tested it with a multimeter. Sent from my SM-N960U using Tapatalk
  11. Evaporative emissions sys stuck shut

    W221 S-Class
    Nope not bad. The ecu controls ground on this. I have removed the plug out and connected it to a 12v battery plugged it into the valve and it works. Sent from my SM-N960U using Tapatalk
  12. Evaporative emissions sys stuck shut

    W221 S-Class
    Cleaned valve and reinstalled. I get the same thing. Checked continuity on valve. It rings out. Checked plug on car. Got a light(12 volts) valve will not open. Going to say it is bad. Sent from my SM-N960U using Tapatalk
  13. Evaporative emissions sys stuck shut

    W221 S-Class
    The filter ripped when gently remove. I will try cleaning it Sent from my SM-N960U using Tapatalk
  14. Evaporative emissions sys stuck shut

    W221 S-Class
    Hell ya thanks. I will try it in the morning and post back. Do u recommend getting a real scanner? Sent from my SM-N960U using Tapatalk
  15. Evaporative emissions sys stuck shut

    W221 S-Class
    09 s550 65000 mile. Just got this code. P2422. I need some advice. It looks like it is attached to the charcoal canister under the right rear tire. Part number 0014701393. Is this the right part and do I have the location right. do I have to change out the charcoal canister as well...
  16. Maintenance service 2009 s class

    W221 S-Class
    Thank you. Do u have the same for ml350 2008? Sent from my SM-N960U using Tapatalk
  17. Maintenance service 2009 s class

    W221 S-Class
    I got a service b message on my instrument cluster where can I get the info on performing these. Thanks Sent from my SM-N960U using Tapatalk
  18. Another rear sam problem

    W164 M-Class
    Thank you for the help. You save me a bunch of money. I was able to find one on the internet for 270. Installed it and everything works fine. I didnt even need to have it programmed. Sent from my SM-N960U using Tapatalk
  19. Another rear sam problem

    W164 M-Class
    Yes. And cleaned the light corrosion I found with rubbing alcohol and a tooth brush Sent from my SM-N960U using Tapatalk
  20. Another rear sam problem

    W164 M-Class
    Yes. The first pic the the original sam Sent from my SM-N960U using Tapatalk
1-20 of 42 Results
Top