Mercedes-Benz Forum banner

Recent content by Lonnie37

  1. Static fm and am after new pioneer radio install w211

    Audio & Telematics Forum
    Working good now guys I had used the antenna from GPS unit not knowing there was another antenna behind the gps unit and fuse box Now I’ve attached to that antenna connection a lot better radio reception. Thanks for help I appreciate it.
  2. Static fm and am after new pioneer radio install w211

    Audio & Telematics Forum
    Yes checked not on local
  3. Static fm and am after new pioneer radio install w211

    Audio & Telematics Forum
    By standard antenna I meant an old car radio antenna Not the w211’s amplified shark fin antenna
  4. Static fm and am after new pioneer radio install w211

    Audio & Telematics Forum
    Standard antenna is an improvement about 80% now still get static and inside garage no reception at all but it’s definitely better but nowhere near as clear as command unit
  5. Static fm and am after new pioneer radio install w211

    Audio & Telematics Forum
    Ok thanks I have an old antenna that’s not amplified I’ll give that a try this afternoon. I hadn’t thought of trying an unamplified antenna. The scratchy sound came regardless if car was running or off. Fingers crossed this standard antenna does the trick.
  6. Static fm and am after new pioneer radio install w211

    Audio & Telematics Forum
    It’s a little confusing as the original command unit did not have an antenna plugged into the back so I’m assuming it all ran thru from the rear via the fibre optics. So when I checked in the rear of the car where I found Amp etc I’ve found the antenna connection into that rear Amplifier, So ive...
  7. Static fm and am after new pioneer radio install w211

    Audio & Telematics Forum
    No I’m not using the original amp, as I’ve unplugged the antenna connection from the back of that amplifier and connected that onto my 5 metre ext from headunit to back of car, that’s where I’ve plugged in the new adaptor amp and powered it from one of the rear fuses next to original amp. I...
  8. Static fm and am after new pioneer radio install w211

    Audio & Telematics Forum
    Hi I have a 2007 e350 w211 with fibre optic and have replaced command with pioneer z5150 by using aftermarket aerpro harness for plug and play. Everything worked out great including steering wheel control except the reception of FM and Am , I know it has amplified antenna and have fitted an...
Top