Mercedes-Benz Forum banner

Reaction score
8

Profile posts Latest activity Discussions Media Albums About

  • Nikkislayer7 ·
    Hello Bazzle! I don't know if you still hang around these parts, but I would like to say thank you for all the help and information you have posted on the website. It is TRULY appreciated!
    tom h ·
    You come highly recommended so I hope you can help. My 1999 SLK 230 has a check engine light on posting codes P1235, P1236 & P1525. What can be the problem, what is the fix, and how much will it cost?

    Thanks
    rvergel ·
    I was reading your post on how to replace the front brakes pads for a slk 230. I saw the equipment list needed along with photos, however, I did not find the instructions on how to replace them. Are they posted some place else?

    Thanks,

    Russ
    lannylord ·
    I just got a 2000 SLK230 and thinking about putting 17 x 8 rims and wheels on it? did you have any issues with yours?

    Thanks,
    Lanny
    jorallo ·
    Bazzel you are amazing I just did my breaks awesome. ... Great break job write up it was weird tho my t40 didn't fit oh well thanks a mil.
    Stoli2112 ·
    Bazzel, Forgive me for coming to you directly, but after reviewing many posts by you, I feel you are knowledgable. I have a 1999 SLK 230 and recently perform a Backup light switch fix (http://www.benzworld.org/forums/r170-slk-class/1369483-reverse-switch-fix-no-backup-lights.html). After fix the back lights now work. After reinstalling gear shift assembly I developed other issues. I seem to now be "limp mode" and also have a BAS/ESP light on. After exhausting reading, I am not sure if this is coinsedental or is it something I did...? What is the circuit board function in that Gear Shift Assembly? I read brake switch for the BAS/ESP, and MAF for the Limp, but I feel I caused it as it was runiing fine prior to my fix.
    dkgmeg ·
    Hey Bazzle I have been surfing the site and thought you might be able to help me with this question... I work away from home, was gone for a couple of months, got home, had to charge the battery on our 99' slk 230 k, when I fired it up I had 5 obdII codes I cleared them all, (after writing them down) and the cel went away and has not returned... yet. Should I be concerned? Thanx
    dreamer62 ·
    Hi Bazzle. I just bought a slk 230. The roof working for about 2 weeks then failed. We replaced the left trunk cylinder. It is full of fluid. The trunk opens and the roof releases then the sequence stops. The roof never retracts. Do you have any ideas?
  • Loading…
  • Loading…
  • Loading…
  • Loading…
  • Loading…
Top