Lomtevas's 2015 GL350 BTC - Page 15 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #141 of 144 (permalink) Old 03-14-2019, 06:00 AM
BenzWorld Junior Member
 
Date registered: Jun 2015
Posts: 16
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by joeboch348 View Post
You seem to be an expert. I have 2 questions for ya.

1) Tires. My tire guy came up with the original run flats or Michelins. I went with the Michelins for a smoother ride, but 40k miles later I need new tires. I wasn't happy with them either the edges get peeling off little chunks.

I went with Michelin Defender LTX M/S tires. They’re not the exact replacement size but I’m extremely pleased with them. See my comments under my tire post in this forum.

Todd


Sent from my iPhone using Tapatalk
ctpj is offline  
Sponsored Links
Advertisement
 
post #142 of 144 (permalink) Old 04-16-2019, 01:23 PM
BenzWorld Member
 
Date registered: May 2014
Vehicle: 2015
Location: Denver, CO
Posts: 51
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Awesome post - wish U did videos of all these maintenance jobs. Mine 2015 GL350 just got out of warranty and I am trying to see if I can do some of those. Seem like MB is trying to make it hard for the owners to do so - even a simple task of finding parts number isnt that simple with that SUV. I couldnt find it in my manual anyway - thus extra Thanx to U.
Is there a consensus as far as where to buy parts for MB - look like Amazon carry a lot of those. Is that where U get yours?
Ajbolit is offline  
post #143 of 144 (permalink) Old 05-04-2019, 04:42 PM Thread Starter
Lifetime Premium Member
 
lomtevas's Avatar
 
Date registered: Nov 2006
Vehicle: 1986 190E 2.3-16, 1992 190E 2.3, 2014 CLA250 and 2015 GL350 BTC
Location: new york city
Posts: 2,324
Mentioned: 0 Post(s)
Quoted: 56 Post(s)
Lifetime Premium Member
Send a message via Skype™ to lomtevas
(Thread Starter)
Check Engine Light at 84,180 Miles

In response to the previous question, I use only dealer provisioned parts as shown throughout this blog.

I discovered this check engine light this morning. I drove to a filling station to fill her up, and then I returned to do some troubleshooting.

I lifted off the plastic motor cover and commenced unplugging and replugging all the electrical connectors I could find. I restarted the motor and the check engine light was no longer on.

I went and retrieved my Xentry system with multiplexer. I ran a diagnostic and discovered that the diesel's soot particulate filter sensor had a malfunction. I also noted that the 360 Degree camera system has an internal fault (which I knew from before), and the audio system has a fault.

I cleared the faults and we'll see if they return.
Attached Thumbnails
Click image for larger version

Name:	59299327_10217561973495180_3552417065983803392_n.jpg
Views:	7
Size:	56.7 KB
ID:	2509758   Click image for larger version

Name:	59701006_10217561973695185_8642401955437608960_n.jpg
Views:	10
Size:	60.6 KB
ID:	2509760   Click image for larger version

Name:	59547158_10217562575350226_5504637821236805632_n.jpg
Views:	8
Size:	63.1 KB
ID:	2509762  

The home of the two 201's.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by lomtevas; 05-05-2019 at 05:24 AM.
lomtevas is offline  
Sponsored Links
Advertisement
 
post #144 of 144 (permalink) Old Yesterday, 03:44 PM Thread Starter
Lifetime Premium Member
 
lomtevas's Avatar
 
Date registered: Nov 2006
Vehicle: 1986 190E 2.3-16, 1992 190E 2.3, 2014 CLA250 and 2015 GL350 BTC
Location: new york city
Posts: 2,324
Mentioned: 0 Post(s)
Quoted: 56 Post(s)
Lifetime Premium Member
Send a message via Skype™ to lomtevas
(Thread Starter)
Check Engine Light at 84,514 Miles

The check engine light appeared again after 350 miles. I connected the Xentry system and again saw a soot particulate filter sensor failure. I then bought the three soot particulate filter sensors and await their arrival at the dealer's.

Then, suddenly, the check engine light went out, but the sensors will be replaced because Xentry alerted twice on the same problem.
Attached Thumbnails
Click image for larger version

Name:	60644721_10217652511478573_1443311682372763648_n.jpg
Views:	2
Size:	52.7 KB
ID:	2513362   Click image for larger version

Name:	60279845_10217652511558575_9049399327058821120_n.jpg
Views:	2
Size:	68.5 KB
ID:	2513364   Click image for larger version

Name:	60338955_10217652511998586_1667108095861456896_n.jpg
Views:	2
Size:	66.4 KB
ID:	2513366   Click image for larger version

Name:	60433625_10217652512838607_2765867013438963712_n.jpg
Views:	3
Size:	65.4 KB
ID:	2513368   Click image for larger version

Name:	60303738_10217652522238842_8345837401406439424_n.jpg
Views:	2
Size:	73.9 KB
ID:	2513370  

Click image for larger version

Name:	60394210_10217653323658877_2467203878257426432_n.jpg
Views:	2
Size:	60.2 KB
ID:	2513372  

The home of the two 201's.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lomtevas is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > X166 GL / GLS-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome