Lost power/boost - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-07-2019, 01:10 PM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2019
Vehicle: 2008 R320 CDI
Location: Toronto
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
Lost power/boost

Hello
Would like to know if someone experience similar situation or can tell where to start diagnostics. Have my 98 R320CDI only for few months and kind of like it )
Car starts and idle fine when on Parking and accelerator is press rpm goes up no problem but when driving does not want to downshift gears stays less then 2000rpm and it takes a while to get to the speed (80km)
when I use paddle shifters there is no problem with shifting or RPM.
Engine light on
Thanks
Martin
Attached Thumbnails
Click image for larger version

Name:	20190306_212032.jpg
Views:	12
Size:	39.6 KB
ID:	2494682   Click image for larger version

Name:	20190306_211415.jpg
Views:	14
Size:	45.0 KB
ID:	2494684   Click image for larger version

Name:	20190306_210915.jpg
Views:	14
Size:	65.5 KB
ID:	2494686  
baca240 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-18-2019, 07:24 PM
BenzWorld Newbie
 
Date registered: May 2019
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Almost same problem here

I had to replace the diesel particulate filter (the main catalytic converter that's visible). It was breaking up inside. I found a replacement on Ebay. But the main problem came from an exhaust port that was directly in front of the tension pulley. Somehow the tension pulley made a whole in that port and was losing air/boost/pressure. My expected $3,000 job turned into around $1100, which included labor.
Mike Mosley is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W251 R-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Vintage Images of a Lost Age: A Photographic Tour of 19th Century Germany Teutone Off-Topic 5 01-24-2013 06:44 AM
Lost Tribe Scams alchemy Off-Topic 4 12-15-2012 10:04 AM
Oktoberfest in Numbers Wedding Rings Lost, More Brawls Found Teutone Off-Topic 1 10-08-2012 03:26 PM
The World from Berlin 'Without a New Beginning, Athens Is Lost' Teutone Off-Topic 8 02-14-2012 02:07 AM
95 w140 s500 lost all power richardandleela W140 S-Class 1 12-31-2006 11:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome